Question

  • Creator
    Topic
  • #2140592

    My PS5 isn’t turning on… i have tried a ton of things. Nth WORKS!!

    by i170111 ·

    I have tried moving to a cooler place as it initially was heated. then tried forcing start. i am afraid i don’t wreak havoc. so i m tryna be patient and praying it gets on miraculously….

You are posting a reply to: My PS5 isn’t turning on… i have tried a ton of things. Nth WORKS!!

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    Replies
    • #2416827

      It’s well inside warranty.

      by rproffitt ·

      In reply to My PS5 isn’t turning on… i have tried a ton of things. Nth WORKS!!

      Make the call to Sony next. They’ll step you through what to try (yes I’ve had to call other units in before.) Just one thing. Beware of the FAKE SUPPORT SITES> Start with sony.com

      • #2416826

        PS5 Support came of no use

        by i170111 ·

        In reply to It’s well inside warranty.

        I’m not a US resident,
        first i had to buy the PS5 at a heavier price
        second, the PS5 support is like inaccessible from here

        and now it won’t turn on.

        Is there any other way?

    • #2416825

      PS5 Support helped

      by i170111 ·

      In reply to My PS5 isn’t turning on… i have tried a ton of things. Nth WORKS!!

      I contacted their britian support and they helped me fix
      Thanks (link removed by moderator)

      • #2416814

        Thanks for the update.

        by rproffitt ·

        In reply to PS5 Support helped

        Sorry to read you paid what essentially was a scalper or worse for your PS5.

      • #2416813

        Just curious

        by birdmantd ·

        In reply to PS5 Support helped

        What was the issue ?

        • #2416812

          I don’t know myself

          by i170111 ·

          In reply to Just curious

          The issue was solved by letting it beep twice and then it started displaying and my life came back.
          i guess we are not allowed to share links even of official websites like: https://www.playstation.com/en-gb/support/ on forums as they got removed but that particular blog saved my day and deserved to be credited. the support was a bit unclear itself

Viewing 1 reply thread