General discussion

Locked

Name of Last User

By Jorgy1 ·
I administer a network that has extremely restrictive policies in place for desktops. I am running a Windows 2K server with Group Policies. I have configured the policy that says that the last user name will not appear on the logon screen, but the policy won't take. Any ideas???? The workstations were running Windows 2K Pro, policy wouldn't work and now are running XP Pro and still it won't work. I've looked at the Microsoft site and they all say it should work.

This conversation is currently closed to new comments.

12 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Joseph Moore In reply to Name of Last User

Are you setting the correct entry? In GP, it is Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options.
The value to set to Enabled is Do Not Display Last User Name.

Just set that to Enable, save the GP, and that's it.

Do other GP settings you have set work?

Collapse -

by Jorgy1 In reply to

Poster rated this answer.

Collapse -

by Jorgy1 In reply to Name of Last User

Yes, I enabled that exact policy and yes, all of the other policies that I have configured (either enabled or disabled) have worked. This seems to be the only one.

Collapse -

by Jorgy1 In reply to

Poster rated this answer.

Collapse -

by CG IT In reply to Name of Last User

try using the domain controller and domain security policy in administrative tools and see if that will work instead of group policy though can't imagine why your group policy doesn't take [ except that the default GP refresh rate is 90 minutes with a 30 minute + or - windows [so all clients dont ask at the same time]so if you create the GP and not reboot the clients might take up to a hour and a half to propogate down to workstations]. might try reboot a client and see......

Collapse -

by CG IT In reply to

Ok I run W2K Server with both XP and W2K workstations and haven't had a problem getting the CTL+ALT+DEL and no last user name shown to work. Here's how I do it.
For the PDC I use the domain controller security policy in the administrator tools snap in. open up the domain controller security policy and expand security settings, expand local policies and then click on security options. scroll down to "Do not display last user name in logon screen" enable it. Click ok. close all windows. That takes care of the PDC.
For workstations, open the domain security policy in the administrative tools snap in. expand local policies, click security options. scroll down to "Do not display last user name in logon screen" Enable it. close out all windows.
This should do the trick for ALL workstations on the network [good idea to have em all require that anyways].

If you use Group policy via the mmc add/remove snap in and use the default domain policy, under computer configuration, windows settings, security settings, security options, "do not display last user name in logon screen" make sure that is enabled [should be if you enabled it in domain security policy via the administrative tools snap in]. If you've done this, a possible problem is that when you first create the domain group policy snap in, it will ask local or domain, local won't work, has to be for the domain. Also, once you make any changes. You have to save it [and give it a name like defaul group policy else it will have a name like console 1 and others won't know what the heck it is ]. If your trying to require security setting to only a few computers within a group or organizational unit, then you have to apply that policy to that particular group or OU. Let us know if your trying this domain wide or just a select group or OU. Would go a long way in understanding the problem.

Collapse -

by CG IT In reply to

ok if your using the mmc group policy snap in to apply policies and have problems getting those policies to take effect, need to know a couple of things. 1) are you opening the default domain group polciy snap in? or local group policy? 2) if domain group policy are you setting group polcy to computers or users? 3) what account are you using to set group policy [have to ask] 4) are you saving the console [have to ask] 5) have you tried rebooting the server [have to ask] 6) after rebooting the server have you rebooted ALL workstations [have to ask that to]

If you've done all this, and still a no go, I would recommend that you get two computers and setup a mini test network one PDC one workstation and do a clean install of W2K server and a clean install of W2K [or XP] and leave the W2K server with default install values [do not configure anything else once youve set this up] Then try and set the "do not display last user name and require the CTL+ALT+DEL with the default group policy mmc snap in and see if it works. If it does, you have some security configuration in your production network which is prohibiting inherited policies from being appled. Locating that might be a chore.

Collapse -

by CG IT In reply to

another thing to look at is which account your using to create the group policy. Enterprise Admin, Domain admin or just the administrators group. This is a long shot but try adding the domain admin group to the account your using to setup the group policy[even if the account your using is the default administrators group].

Collapse -

by Jorgy1 In reply to Name of Last User

I will try your suggestion. The only thing I can think of is a problem with Server 2000. I've been vigilant about doing updates and have researched this problem till my eyes are crossed. I've been trying to make this policy take effect for almost a year now so it's not a matter of refresh rate. We've even had an upgrade in the process to XP from 2K and still no luck. I'll let you know how I make out. If nothing else, will probably upgrade the server next year so we'll see if that does it.

Collapse -

by jeaster In reply to Name of Last User

the policy specified above should work, however, you might need to force a policy update...

Back to Windows Forum
12 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums