General discussion

Locked

nat in squid

By peyknet_isp ·
I have configured a cache server with fedora core 3.I am going to use my cache server between cisco AS5300 and cisco router 1841.I want my cache server nat my dial up customers and redirect the HTTP requests to port 3128 .Of course i did it but it does not work properly it gives wrong pages to customers.

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Toivo Talikka In reply to nat in squid

I do not know either of the Cisco devices, but doesn't NAT as a network function belong to the AS5300, not the cache server?

If you use the standard port 3128 in squid, the router device directing the incoming traffic from your dialup customers to the cache server running squid has to do port forwarding of port 80 to port 3128, or the client devices set port 3128 in their proxy settings.

Collapse -

by dimon_quaker In reply to nat in squid

1) Use port-redirect to proxy server.
# iptables -t nat -A PREROUTING --src <LOCALNET> --dport 80 -j DNAT --to-dest <PROXY_IP>128
where <LOCALNET> - you local network, ex. 192.168.55.1/24

2) Configure squid as transparent-proxy server.
Add this lines to "/etc/squid/squid.conf":
httpd_accel_host virtual
httpd_accel_with_proxy on
httpd_accel_uses_host_header on

Back to Linux Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums