General discussion

Locked

NAT setup

By rmccabe ·
I need to set up NAT on a Cisco 2621. I have a number of workstations on subnet 192.168.0.0/24 that need to pass DNS requests to subnet 161.228.27.0/23

I configured interface FastEthernet 0/0 as the inside interface with ip address 192.168.0.98/24. FastEthernet 0/1 is configured as the outside interface 161.228.27.244/23.

I can ping the DNS server from the router but from none of the machines on the 192.168.0.0/24 network.

From here I'm stumped. The Cisco site has helped but my lackof experience with IOS is glaring.

Any help with specific commands or links to such would be appreciated.

Rob

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

NAT setup

by -Q-240248 In reply to NAT setup

Wwhats wierd about your solution is that you have some kind of (you think) translation going, and in reality, you do not. Incoming and then NAT translated outgoing addresses all reside on the same interface (E0/0 or E0/1). You need to simply brush up on the NAT commands from cisco.com and then get your subnets squared away. First you'll need to create a NAT pool (IP NAT POOL....). I'm not sure but I believe you'll be needing to purchase NAT-enabled IOS for your Cisco as well...

Collapse -

NAT setup

by rmccabe In reply to NAT setup

Poster rated this answer

Collapse -

NAT setup

by cavedweller In reply to NAT setup

This doesn't sound like NAT to me either, just routing.

Do the clients have a route to the the dns server? Can they ping both the inside and outside cisco addresses? If they can't your router is not routing correctly.

Also, not really partof your question, just some general info:
In your situation some people set up one local machine as a dns forwarder and point all the other local machines to it to. Usually the more local machines you have the more this makes sense. The forwardedtends to cache dns requests which reduces network traffic. Also, if the remote dns changes you only have to update the forwarder, not the clients.

Collapse -

NAT setup

by rmccabe In reply to NAT setup

Poster rated this answer

Collapse -

NAT setup

by sidney In reply to NAT setup

The litmus test will be to try an extended ping from enable mode (just type "ping" then enter). Enter the DNS server as the destination address and the router's 192.168.0.x address as the source address. If this doesn't work, then there is an issue with the inside/outside configuration. Is your NAT pool configured from the 161.228.26.0/23 network? If it isn't then you might be assigning NAT IPs that get routed elsewhere...

You don't need NAT in this situation unless the DNS server you're talking about is on your ISP's network (i.e. you're using a ethernet drop and some borrowed public IPs to connect to your ISP). If so then I'd make sure the NAT pool is configured using the right IPs otherwise, removing the NAT config should clear this up.

Collapse -

NAT setup

by rmccabe In reply to NAT setup

Poster rated this answer

Collapse -

NAT setup

by rmccabe In reply to NAT setup

This question was closed by the author

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums