General discussion

Locked

Need Help Installing PCI Sound Card

By hamant5 ·
I recently bought an 'Audio Excel' PCI Sound card with 6 Channels P/n 9410490020 Code:Av51X Series V.2-E. Upon placing the hardware into motherboard and booting up PC, new hardware was 'detected' and the relevant Drivers were installed into the Computer. However upon restart of PC, as soon as I click my 'profile' icon and 'loading your personal settings appears', just at the point one would hear the 'welcome' audio clip, the PC suddenly freezes - no mouse, no keyboard. I cut the power and remove sound card upon which the computer works perfectly. Does anyone have any suggestions how I can get this sound card to function properly?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by n.u.r.v. In reply to Need Help Installing PCI ...

You did not give the specs for your PC,.

Did you use the manufacturer supplied drivers? Some of these drivers are not Microsoft tested so you might need to boot the PC in safe mode to uninstall the Hardware & drives to be able to enter you systems again.

Check the install manual for your hardware for any special stuff you need to do.

Collapse -

by HAL 9000 Moderator In reply to Need Help Installing PCI ...

OK first things first start your Computer in Safe Mode and remove all the sound drivers from the Device Manager.

If you have On Board Sound you'll need to disable this in the BIOS or if you have one of the older M'Boards by changing a Jumper on the M'Board, then reboot the computer just to make sure it's working properly.

Once you have it starting properly shut sown and reinstall the Sound Card and add the drivers as required by the system. At this stage you should be given a prompt to restart the computer or keep working in Windows chose the reboot option and see what happens. If it now works then you have solved your problem when you removed the old Sound Drivers and if it doesn't try inserting the sound card in a different PCI Slot you may have to juggle PCI cards around here to get things to work properly.

If you can not get the unit to work which I think that you will because it is showing a screen and reaching the Log On Screen you had a good old Software Conflict that most likely originated from the old Sound Card or drivers that where installed.

I think that you'll find that fixes your problem.

Col

Back to Hardware Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums