General discussion

Locked

Need help with CD-ROM installation...

By hglimpse ·
I recently had to swamp out cd drives between pc's at work. Now I cant get windows to recognize them. They were identical drives (Creative CD5230E), Im getting power to it, but it looks as if it isnt even installed anymore. I kinda got thrown into this situation and now Im clueless. Anybody that can guide me through it? Oh, and we no longer have the software for the drives either (go figure).

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Need help with CD-ROM installation...

by Brian Lusk In reply to Need help with CD-ROM ins ...

Well, it's not really enough information, but here are a few suggestions:

1. Ensure pin one on your cable is going the right direction.

2. Get the drivers and installation instructions from the Creative Labs website (www.creative.com) and install the drivers per the instructions.

3. Ensure you have the Master/Slave jumper set correctly on the drive.

Now, some questions:
1. Why did you swap out the drive in the first place? Did it stop working? Have you tried a different model andmanufacturer drive to see if it would work?

2. Are you certain the IDE interface on the motherboard is working correctly? Is your cable free from defects, nicks or other damage?

3. Are you working on an older computer system, say over 6 yearsold? Could the CD drive have been plugged into a sound card that has stopped working?

I hope this helps you get on the right track.

Brian Lusk

Collapse -

Need help with CD-ROM installation...

by hglimpse In reply to Need help with CD-ROM ins ...

Poster rated this answer

Collapse -

Need help with CD-ROM installation...

by zlitocook In reply to Need help with CD-ROM ins ...

the last post was great but you can test the ide connection by pluging in the harddrive cable into it if the computer sees the hard drive the connection maby good.

Collapse -

Need help with CD-ROM installation...

by hglimpse In reply to Need help with CD-ROM ins ...

Poster rated this answer

Collapse -

Need help with CD-ROM installation...

by Will962 In reply to Need help with CD-ROM ins ...

A little more detail for you..

1. Ensure pin one on your cable is going the right direction.

Both the IDE connections (motherboard and drive) are marked with the number 1 to indicate which end is pin 1. The IDE cable has a red stripe on the side that is pin 1. On the drive, pin 1 is usually closest to the power plug.

2. Get the drivers and installation instructions from the Creative Labs website (www.creative.com) and install the drivers per the instructions.

3. Ensure you have the Master/Slave jumper set correctly on the drive. It needs to be established as 'Slave'. Do this only if the CD Drive is sharing the same IDE Cable as the Hard Drive.

Another possible step would be to remove the CD ROM from the system. Go to control panel>sytem>devices to see if the CD ROM is listed there. If so, Highlight it and click 'Remove'. Restart the system. Windows should see that the 'new' device is there and attemp to load drivers for it. If you have already downloaded them from the website, use that, but the Windows CD may have it , although it may be an older version.

Now, a question:
1. Did you troubleshoot the ribbon cable (if it is a seperate cable from the hard drive ribbon cbale) by swapping it with the hard drive ribbon cable? If it is seperate, swap IDE ports on the motherboard.

Collapse -

Need help with CD-ROM installation...

by hglimpse In reply to Need help with CD-ROM ins ...

Poster rated this answer

Collapse -

Need help with CD-ROM installation...

by hglimpse In reply to Need help with CD-ROM ins ...

This question was closed by the author

Back to Desktop Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums