Question

Locked

Net Framework Service Packs hang at Registering System.Enterprise.dll

By estah ·
This computer had all the service packs and the current udates. What happened to it I don't know. I was downloading priorty updates on the Microsoft Windows update site, when it could not download a update to .Net Framework 1.1, I contacted Microsft support and was told to download the dotnetfx_cleanup tool.zip which I did & did all the steps Microsoft support said to do. Then i began to install the Microsoft .NET Framework Version 1.1 Redistributable Package . It hung at Registering System.Enterprise.dll. So I downloaded DetectDotnet.zip to see what service packs the machine had. It said I did not have .Net Framework v1.0. I downloaded version1.0 and tried to install it, it too hung at Registering System.Enterprise.dll.-- Now begins the problem.

I no longer have any service packs on this machine, and cannot install them again because of Registering System.Enterprise.dll hangs.

I've done all these steps after visiting many forums on this subject::

1. Ran the dotnetfx clean-up tool --multiple times & with the multiple reboots before the Net Framework v 1.0 install.

2. Ran the Microsoft Installer Repair Tool, and msicuu2.exe.

3. Scanned my computer with Super AntiSpy ware, and Avast Anti-virus.
4. Defragged the harddrive (one person at a forum i visited suggested it).

5. Manually removed all .NET files from computer and registry according to the MS knowledge base article numbers.

6. Turned off the 'Distributed Transaction Coordinator'.
7. Tried running install from the Windows update website, installation still hung up-- left on one hour-- and the progress bar went half way and stays there.

8. Disabled all unneeded start-up items via WinPatrol.

9. Uninstalled, reinstalled Comodo Firewall.

10. Ended unneeded processes in Task Manager.

11. Turned off DEP.
12. Did the correct edits to the boot.ini file. I changed it back when this one didn't work.

13. Did all the following via the Run line:
regsvr32 wuapi.dll
regsvr32 wuaueng.dll
regsvr32 wuaueng1.dll
regsvr32 wucltui.dll
regsvr32 wups.dll
regsvr32 wups2.dll
regsvr32 wuweb.dll
Again turned off Avast Anti-Virus & Comodo firewall, then:

tried for 5th time to install The .Net Framework v 1.0 and it still hung at Registering System.Enterprise.dll and it would not install.
tried for 4th time to install The .Net Framework v 1.1 and it still hung at Registering System.Enterprise.dll and it would not install.
I am now having problems getting on the internet--browsers won't load any website.
I'm at a loss of what to try next. Any help would be greatly appreciated.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well as you have now turned a more or less working system to scrap

by OH Smeg In reply to Net Framework Service Pac ...

And it's almost unusable have you considered wiping and reloading?

I believe if you have ,NET Framework 2 or higher you don't need the .net framework 1 but as by now the system is both unstable and not working correctly I think you have gone way beyond a Repair/In Place Install and need to use a Wiping Utility like Boot & Nuke

http://www.dban.org/

of Kill Disc

http://www.killdisk.com/downloadfree.htm

wipe the HDD and then using your Install Media install Windows from Scratch.

You'll need to have all of your Other Install Media and Backup your Data before you start and if you have a Recovery partition on the HDD it's probably better to run that rather than attempt to wipe the HDD.

Col

Collapse -

Agree with Col

by Tony Hopkinson In reply to Net Framework Service Pac ...

Once you get a service pack collision, it's a matter of luck whether you can uninstall / reinstall etc.

Nuke it and start again. Even if you get past this problem, you've no clue whether it's right, and every funny from now on, you wonlt know who did what to whom.
In my experience it's not worth the effort of trying to rescue it.

Collapse -

System.EnterpriseService.dll

by estah In reply to Net Framework Service Pac ...

Does anyone know how to do a system recovery to have a factory refresh Windows XP in a Dell computer--I have forgotten. I can't remember which f button.
I am trying to fix this computer for my sister--she is on a limited budget--guess which computer is accessing the internet. I will fight for this Windows Xp---it is a wonderful OS.

Collapse -

Reponse To Answer

by OH Smeg In reply to System.EnterpriseService. ...

Which Dell?

The model makes a difference some are F9 and some are F2.

Col

Back to Malware Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums