I’m having problems with Windows 2000 servers dropping netbios connections. Users have a drive letter mapped to the server, everything is working fine, then “out of the blue” the server will stop responding to all NetBIOS requests. The server responds to PING, Terminal Services, … but any attempt to connect via a drive letter or UNC fails. Only a reboot is able to bring it back to life. I moved this particular drive letter to a completely different server and the problems goes with it. It is completely random and driving me crazy. Any help would be MUCH appreciated.