Question

Locked

Network Adapter problem (Code 39)

By m_zs_m ·
Hello,
First of all, the laptop I am having issues with is a Sony Vaio VGN-FS93G with 1.5gig RAM, 1.84ghz, intergrated network/video. Uses a Intel PRO 100 VE network connection and Intel PRO 2200 BG Wireless.

I recently have encountered a problem I never seen before. My network adapters in the Device Manager are indicitating a problem with the hardware to be started and giving me the windows Code 39 error. I have tried uninstalling the drivers and installing the original drivers and the problem persists. I have also tried uninstalling and disabling the adapters and rebooted, same issue appears. I have not formatted yet because there is software on the PC I need which I have lost the original discs to. I am thinking it might be a hardware defect or damaged but I have a seperate PCI network card and it gives me the same error still. I have also done a clean scan of adware and virus to determine if my PC is infected or not.

These problems occured after a defragmentation, virus scan and uninstall of a wireless program from intel. Everything else on the laptop is running fine except no network detection at all due to the error in Device Manager. I believe there is nothing wrong with the network adapter on the board since the PCI card was giving the same results but I could be wrong. I would go back to the retailer but I believe I have voided my warrenty now since I have brought this laptop back to Canada (I originally bought it from Hong Kong) and would be too much trouble to go back or send it over.
If anyone has any advice or solution in fixing this problem or need more specific details I may be missing, please let me know.

Best Regards,
David

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

I would try this...

by tonylewis In reply to Network Adapter problem ( ...

First, backup the regsitry key I'm about to mention, then try deleting the registry key for your network adapter under HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318} . (Note: I think your key name will be the same but you will need to verify by looking at the right side in registry editor. If it's not, then just highlight each key under HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/Class/HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\ until you see one that says "Network adapters". Reboot and reinstall the driver.

Let us know how things work out.

Cheers,

Tony

P.S. It seems the formating here won't let me put the key name on one line so here it is broken up:

HKEY_LOCAL_MACHINE
/System/CurrentControlSet/Control
/Class/HKEY_LOCAL_MACHINE\SYSTEM
\CurrentControlSet\Control\Class
\{4D36E972-E325-11CE-BFC1-08002bE10318}

All the above is one key.

Collapse -

Did it last night

by m_zs_m In reply to I would try this...

Hello,
I have tried doing as you advised and now I am not sure how to gain back the network adapter options. They did not detect nor did reinstalling drivers do anything. Seems like I may need to reformat.

Back to Malware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums