General discussion

Locked

"Network cable unplugged" in only 1 OS

By semmelbroesel ·
Hi,

a client had a bunch of spyware that I removed (one of them resisted a lot). Now it keeps saying "a network cable is unplugged", and I cannot get any connection.
I tested the cable itself, and it works fine.
When I start the PC using a CD that starts a miniature version of XP I get a working TCP/IP PING connection to google. I think that rules out a broken cable or NIC :)
Question remains: What can I do to repair it?
I tried the following:
-WinSockXPFix
-delete and reinstall drivers
-HiJackThis/Spybot/Adaware to check for possible TCP hijacks

I should also add that I tried installing Spybot and Ewido to scan for spyware, and both programs could not access their own databases that come with the installation.
One piece of spyware could not be removed from the Registry because one sub-entry could not be accessed - probably corrupted Registry.

So, there's two questions:
1. Any idea how I can repair XP to again accept the network cable again?
2. Can a corrupted Registry be repaired as opposed to restored from a backup, or is there another thing I can try?

I also tried restoring the Registry from a month ago, and it didn't solve problem 1. Restoring the Registry from about a week did not solve problem 1 or 2 (I did not check the month old backup for problem 2).

As usual, any help is greatly appreciated!
Thanks!

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ghimpe-- In reply to "Network cable unplugged" ...

Boot your XP CD and choose Recover.

Collapse -

by willcomp In reply to "Network cable unplugged" ...

I have used winsockfix.exe for quite a while with good success. Don't know if WinsockXPfix is same program. Here's a link:

http://www.tacktech.com/display.cfm?ttid=257

Try running winsockfix and see what happens. Believe that you have a network configuration or windows socket problem.

Although this may seem stupid, ensure that network adapter is not disabled (look in network connections).

Dalton

Collapse -

by semmelbroesel In reply to "Network cable unplugged" ...

Yes, this Winsock fix is the same, and I already tried it. I disabled and re-enabled the NIC multiple times without success.
One thing I have not tried is to change the connection speed to 100Mbit instead of Auto, and I will try the LSPFix (spyware removal).
I don't want to recover to an older state. I already recovered older versions of the Registry without success, and recovering to an old state would bring the hundreds of spyware programs back that I spent an hour removing...
I am thankful for everyone who has answered so far, and I am still hoping for more possible solutions - I have to fix this within the next 2 days...

Collapse -

by HAL 9000 Moderator In reply to "Network cable unplugged" ...

First remove the divers for the NIC and then shut down. Then remove the card itself if it isn't built onto the M'Board and reboot. If it is an On-board NIC go into the BIOS and disable it and then reboot and run any cleaning tools that you have before shutting down again and reinstalling the NIC or enabling the NIC in the BIOS.

For a registry repair tool that may work if the thing isn't to badly damaged try System Mechanic 5 {not the pro version} which you can find at

http://www.iolo.com/sm/download.cfm

If that doesn't work it's reload time and remember to not only strip the system to do a clean install but wipe the Boot drive with a utility that writes 0's to every sector to totally destroy anything that is already there. If you just reformat with the Format option on the install of XP it only writes to every 3 sector so any infections can remain and become active on a clean install. You should be able to find one of these DOS utilities at a HDD makers site I believe that Maxtor still has one free to download but you could try other sites as well.

Lets know how you go.

Col

Collapse -

by ch_orin In reply to "Network cable unplugged" ...

I have 1 tip that has worked many times for me...
1) Go into [Network connections] then [Local Area Connection]. Right click and on the drop down menu choose "Properties". Once here, select the "configure" button next to your adapters name. Goto the Advanced tab abd check the "Link speed and duplex settings"- if this isn't set to auto-negotiate AND it is set to a speed the card can recognize, it will squak "Network cable is unplugged BUT you will be able to ping anything, response will be slow and sometimes you won't get a reply. Set it to auto and/or find out the correct setting and set it there!

Hope this helps, I've run into this many times
Good luck!

Chris Orin

Back to Desktop Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums