Question

Locked

Network connectivity problems, but *only* on my laptop

By lionheart1982 ·
I've tried everything I can think of, and still nothing. All of a sudden my laptop cannot connect to the wireless network; it hits the router and then says that it cannot connect to the internet. The router is known to be good. I've tried physically plugging in a known good Cat5 cable, and the transfer is slow enough that it won't connect to any sites despite saying it's connected (e.g. sent 100, received 1 and barely goes up from that).

No other computer in our network is affected and is able to access the internet with no problems. It was working fine a few hours ago, but now nothing.

I'm out of ideas on how to fix this, and it's been several years since I've done any real network administration. Any suggestions?

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

what is your OS and network details?

by Neon Samurai In reply to Network connectivity prob ...

Is it a specific Windows version or Unix like OS distribution?

What are your TCP/IP details.

(windows; "ipconfig /all")

My initial thought would be to check what DNS servers are issued by your router or what DNS servers are listed on your notebook. Is it using static DNS servers that are not correctly specified or is the router DHCP issuing invalide DNS server addresses?

(you can blank out your mac addresses if you post the outpout from ipconfig. They are not particularily relevant unless your router is using MAC filtering for wireless connections.)

Collapse -

Details

by lionheart1982 In reply to what is your OS and netwo ...

It's running Windows XP Pro. We just upgraded our domain controller yesterday, but everyone else can acces the internet fine (and as I said, it was working fine a few hours ago).

Running ipconfig gives me this (names anonymized of course):

Windows IP Configuration

Host Name ACME-IT
Primary Dns Suffix ACMEDOMAIN.local
Node Type Broadcast
IP Routing Enabled Yes
WINS Proxy Enabled Yes
DNS SUffix Search List ACMEDOMAIN.local

Ethernet adapter Wireless Network Connection 4:

Connection-specific DNS suffix: (blank)
Description: Belkin Wireless G Notebook Card
Physical Address: 00-17-3F-D7-18-00
Dhcp Enabled; Yes
Autoconfiguration Enabled: Yes
IP Address: 192.168.0.70
Subet Mask: 255.255.255.0
IP Address: fe80::217:fff:fed7::1b0d%6
Default Gateway: 192.168.0.1 (IP Address of wireless router, but we have several routers throughout the office.)
DHCP Server: 192.168.0.1
DNS Servers: 192.168.0.1
fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
` fec0:0:0:ffff:%1
Lease Obtained: Friday, September 05, 2008 1:18:42 PM
Lease Expires: Saturday, September 06, 2008, 1:18:42 PM

Now, we changed over our domain yesterday and I am logging in, although without the wireless started up it uses the cached version at first.

I think the issue has something to do with the fact that it's trying to use the wireless router as a DHCP/DNS server, but it's not connecting to it at all, and I didn't change anything on the wireless configuration. I am not able to ping any other server on the network, either.

One more thing I noticed, that might help narrow it down: When I try to ping another PC on the network, I get a reply from 192.168.0.1 (the wireless router) saying the destination host is unreachable.

Collapse -

More detailsI

by lionheart1982 In reply to Details

It seems to be a subnet issue.. the IP of our main gateway and DNS/Domain Controller is 192.168.1.xxx, while the wireless router uses 192.168.0.xxx. I gave my laptop a static IP address on the domain subnet with a physical network connection, and it's working now. So I will have to troubleshoot that later.

Collapse -

perfect

by Neon Samurai In reply to More detailsI

I generally run my dhcp and wireless out of the same router for small networks but I can add conflicting IP ranges too my list of things to check for now too.

maybe something in your router is trying to run the wireless under a seporate vlan segment. This is a good idea to keep a wireless breach a little more contained; wired and wireless can go out the router gateway but not talk directly to each other.

As an alternative, you could also adjust your network mask allowing both IP ranges to function together if you really wanted.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums