Network Mapping Issue

By speedfreak64x2 ·
I am experience an issue mapping a network drive through a logon script tied to the user account in AD. Every line of my little script works except one. Heres the entire script:
net use p: "\\******\NewCompanyData\CompanyData P" **** /user:**** /p:yes
net use g: \\fileserver\Accounting
net use n: \\fileserver\NetData
net use s: \\fileserver\Network Scanners
net use u: \\******\NewCompanyData\CompanyData P\Users
Line one is of course for authentication purposes, but it also logs into the server share for P as well as U. my problems is mapping the U drive. this command will not work. through the script or from the command line(after authenticating).
I can however map the drive through the gui, to the same location(\\******\NewCompanyData\CompanyData P\Users)

Environment: Machines are a mix of XP and 7. Servers are 2003 and 2008.The share I am trying to connect to is on a 2003.

Any thaughts would be appreciated. I also understand that I could take the easy way out, and simply connect the U drive once and omit it from the script altogether as the P drive access will provide the proper authentication. I am not looking to bandaid the problem I would like to resolve it. Thanks for any Help.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Multiple credentials not allowed

by gechurch In reply to Network Mapping Issue

I suspect it's trying to connect U: with the logged on users credentials. Since you've already mapped P: drive with different credentials, Windows is probably blocking the U: since you can't connect to the same server with two different sets of credentials. (You can test this by logging in without running the script. Use the GUI to map P:, choosing the option to provide alternate credentials. Now map U: drive without alternate credentials and you will see an error about a 'security compromise attempt' or something similar). You didn't mention what error message you got when the script fails to connect U:. What was it? You can temporarily add @pause to the end of the script to see the error message the script pumps out. Also consider commenting out the conenction of P: temporarily and testing as I suspect that is the cause of the problem.

The best way to fix the issue would be to set security on the '\\******\NewCompanyData\CompanyData P' share so that the logged in user has permission. I'd also look at mapping drives through group policy if that's possible. That's a much more manageable way of handling mappings, and you can set rules like 'run once only' or 'run using users credentials' etc. It also means you wouldn't have passwords in plain text that users can see during logon. Note you'd need to install the GPO client side extensions for XP clients first though.

Related Discussions

Related Forums