General discussion

Locked

Network Printing Problem

By TKSolway ·
I have a network with Windows Server 2003 and windows XP workstations. It is setup as a domain. There is a program that needs to send plain text to a dotmatrix printer. I try and map the network share for this printer using Net Use, to lpt2. When I try and send anything to this port Access is Denied. I have tried this with an account that had full Domain administration and local administration rights.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by briantruitt In reply to Network Printing Problem

Is the printer hooked up to the server or one of the workstations? Which ever it is hooked up to I would double check the file and printer sharing. XP and 2003 have "special security features" that make it hard for normal people to share files, printers, or whatever out, especially if you use their Wizards. Have you tried going out through My Network Places and finding the printer that way? If it's shared correctly and everyone is authenticated correctly it should show up. Hope this helps.

Collapse -

by briantruitt In reply to

Has the printer ever worked normally or has this just happened since using Win2k3 and XP? To be honest I've never seen too many dot matrix printers hooked directly up to too many pc's. Worst case scenario you might have to get a little print server. Also, the small majority of dot matrix printers that I've seen, for some reason or another, used IPX/SPX as their protocol of choice. If your printer is hooked directly up to your server try Adding a new printer, select local printer, but create a Network Printer Port. This should ID your printer with IPX, if that's what it wants to use. I'd be interested to know if you understand what I'm saying or if this actually works.

Collapse -

by TKSolway In reply to Network Printing Problem

It does show up properly in my network places and I have published it in the AD. I have to use net use because, windows no longer asks me wether a dos program should be able to use the shared printer.

Collapse -

by SativoComputerServices In reply to Network Printing Problem

You cannot map an existing physical port to anything on a network, so if you have an lpt2 installed, try using a non existant lpt port. Also, when using the command line to do this, remember, to add the /persistant:yes to it. This should help.

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums