General discussion

Locked

network problem since SP2

By ramsr ·
Ever heard of a network card being able to detect a connection only when connected to a particular modem?

A newer computer, a HP Pavillion XP has a problem.
We have had ATT/Comcast Cable modem for a long time. Worked fine.
We use a Linksys 4 port router to share the internet connection with a older Win98se machine, worked fine.
Decided to try Verizon DSL (didn't cancel the Comcast yet), a few problems at first, but then worked fine.
The XP machine got updated to SP2, lost the connection, after resetting the modem & router, seemed OK.
That night and the next day we had about 3 times that the connection got real slow, then eventually wouldn't work at all.
The only way I have been able to get connected on the XP machine since has been hooking it up directly to the Comcast modem.
If I hook the 98 up to either modem, works fine!
If I hook the XP up directly to the Verizon DSL modem or with either modem through the router I get "a network cable is disconnected".
This is all using the same ethernet cable (a new one since the problem started) plugged into the PC.
Updated the Realtek network card driver, no change.
Spent hours talking to Verizon no help. Got a new DSL modem from them, no change.
Spent even more hours over 2 days talking to HP, no help.
I uninstalled SP2, No change. Used device manager to uninstall the network card (about the 3rd time), no change.

We've always had (and kept updated) McAfee Antivirus, Zonalarm firewall, & Ad-aware on both machines.

Any ideas?

Ron

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by CG IT In reply to network problem since SP2

humm try the following:

SP2 has its own firewall enabled when installed so if you've got a firewall already, you should disable the SP2 firewall [accessible in control panel, windows firewall icon]. that might solve some of your connectivity problems.

if you have verizon dsl and use the Cisco/Linksys consumer level router, the WAN router interface needs to be set to obtain IP address dynamically. Verizon DSL provides you with one dynamically with a time to live of 4 hours so don't set any static addresses on the WAN interface. If you use the routers DHCP service, then you need to follow the instructions that came with the router on how to configure computers to use the router. Each browser [netscape/IE/monzilla/etc] has a different configuration for using the router for internet connectivity.

another option which I know works is go the static ip/dns address route. first is to get your DNS addresses from Verizon. you can do this from the status page on the web interface to the router. connect to the router and click on the status tab. when it says DNS copy the DNS addresses. Verizon will normally give you 3. next step is to determine you routers ip address. default for linksys is 192.168.1.1 and if you didnt change it you'll need that as well. copy it down. next step is to disable the DHCP service on the linksys router. configure the PCs TCP/IP address as 192.168.1-2-254 subnet mask 255.255.255.0. Since the routers address is 192.168.1.1 you can give a pc that address. So pick a # between 2 and 254. next is in the gateway address block type in the routers ip address as the router is the gateway out to the internet. that address would be 192.168.1.1. next step is in the dns address block type in the dns addresses you copied down from the routers status page. click ok. make sure Iternet Explorer LAN settings cleck boxes are all clear.

if all else fails, dump verizon ran/jer and stay with comcast.

Collapse -

by sgt_shultz In reply to network problem since SP2

If I hook the XP up directly to the Verizon DSL modem or with either modem through the router I get "a network cable is disconnected".

did you try a crossover cable? of course you have tried repairing the network connection? (right-click, pick repair)

Collapse -

by pierrejamme In reply to network problem since SP2

kept updated is scary. Zonealarm 5, unless recently fixed has caused a myriad of problems.
Quote from User Forum sysop:
"For those going to upgrade to Windows XP SP2 [ Edited ]
MuffinCharizard
Guru
Registered: 08-23-2003


Viewed 15154 times


Windows XP Service Pack 2 is a highly recommended update for all WinXP users, but the upgrade might cause problems with ZoneAlarm if installed while ZoneAlarm is running.

I suggest that you first create a restore point. If anything goes wrong with the installation, then you always have that restore point to go back on. Usually nothing goes wrong, but better safe than sorry.

Download the full installation file of the service pack from the Microsoft web site. The file should be around 200MB. This will allow you to install the service pack offline. After downloading the service pack, disconnect from the internet and in ZoneAlarm, go to the overview tab, click the preferences tab and uncheck "load zonealarm at startup". Now shut down ZoneAlarm along with any other programs you have on (especially antivirus programs) and install the service pack.

After you finish installing the service pack, load up ZoneAlarm and check it to load at startup again. You will probably recieve alerts about changed programs trying to access the internet. Check your program permissions to ensure that everything is correct.

Edit: Oh, I almost forgot to mention! Disable the Windows XP firewall.
Message Edited by MuffinCharizard on 07-16-2004 08:28 AM "
If you haven't been there I suggest you visit the ZA forum at:
http://forums.zonelabs.com/zonelabs
if you have 5.x, you might want to revert to 4.5.454. if you don't have it anymore, get another at:
http://download.zonelabs.com/bin/free/information/zap/releaseHistory.html
XPSP2 doesn't play nice with a bunch of programs, Personally i have blocked it from all our users. I would uninstall it post haste.

Collapse -

by dustyD In reply to network problem since SP2

Agree w/ ans.1...also, when you are connecting directly to the modem, you are using a defined internet connection. (Control panel/Internet Options/Connections.) When you are using the Linksys, you should be using NO defined internet connection, right?
I am having problems with a Linksys BEFSX41 router that I upgraded the firmware on (ouch) Now, very slow downloads and surfing. Worked fine before. I also am now using direct to modem until I get a fix from Linksys.

Collapse -

by ramsr In reply to network problem since SP2

FYI Finally got it working again. It was in the configuration of the Realtek network card. Found this on the Linksys site:

Windows XP
Click on the Start menu, then click on the Run option.
When the "Run" window opens, input ncpa.cpl into the "Open" field, then click on the OK button.
When the ?Network Connections? window opens, check to make sure that there are no Mac Bridges, WAN Bridges, etc. If there are please right click on them and click on Delete.
After completing the last step, double click on the Local Area Connection that controls your network card (Normally will be the only one listed).
When the ?Local Area Connection Status? window loads, click the Properties button.
When the ?Local Area Connection Properties? window opens, click on the Configure button, then click on the Advanced Tab.
When the ?Advanced? area loads click on the Connection Type option under ?Properties?. (This may also appear as ?Media Type?, ?Connection Speed?, ?Link Speed?, please try to find the closest match for your system.)
Change option in the ?Value? area from ?Auto? or ?Auto Sense? to the 10Base-t, 10 half duplex mode, 10 no duplex. This may also vary, depending upon the make and model of the Network Adapter.
Click OK after you made the change then click Close.

It was on "Auto Sense" and I changed it to the 10 half.

Ron

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums