Network share refuses to map.

By pbrowning ·
I'm using a VB loginscript to set up XP clients on an Win SBS 2003 server. A section of the script maps shared drives. All the drives map OK except for one drive which is a users folder on a NAS server so the share path is \\servername\home$\%username%. This simply does not appear in My Computer, there are no errors, it simply doesn't appear. If I change the mapping to \\servername\home$ then it maps fine so it's to do with the username parameter somehow but I don't know what.

Strangely another part of the script sets up desktop shortcuts, one of which links to \\servername\home$\%username% and this link works absolutely fine.

Does anyone know why the mapping using username doesn't work? How can I get it to work?

Thanks for your help.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by Wizard-09 In reply to Network share refuses to ...

Path letter do you have this mapped to \\servername\home$\%username% in AD under network path insure that you have this to map think that is the reason its not working.

So in AD select user name right click properties then select the profile tab fill in the information and this should work.

Keep us informed as to your progress if you require further assistance.

If you think that any of the posts that have been made by all TR Members, have solved or contributed to solving the problem, please Mark them as Helpful so that others may benefit from the outcome.

Collapse -

Can I just clarify this?

by pbrowning In reply to What

Are you referring to the "Home Folder" setting? Every user has the home folder set to "Connect Z: to \\servername\home$\(user).

I've tried changing this setting to 'local path' and also leaving it as a network drive but changing the drive letter. Nothing makes any difference.

I don't think it's the drive letter anyway. The line in question is this:

WSHNetwork.MapNetworkDrive "x:", "\\servername\home$\%username%", True

As shown nothing maps.

If I remove %username% leaving everything else as is then the drive maps to the root of the home$ share perfectly OK.

I must be doing something basic here? Any ideas.

Collapse -


by Wizard-09 In reply to Network share refuses to ...

have you created the folder for the user name on the server in question for example


so server1 would be were i hold all the user profiles.

In AD under users right click user, then properities then profile then do as i said before test that it should work, i dont do VB only BAT file scripts.

Collapse -

User folders

by pbrowning In reply to VB

Yes, the users all have their own folders and they can all access them via the desktop shortcut or via my documents which is redirected there by GP.

Related Discussions

Related Forums