Networking Problem XP Pro - can ping but not view

By dllhell ·
I have small office environment with 3 networked computers (2 wired, 1 wireless), all running XP Pro w/ SP2 (all updated). All in workgroup: CONNECTIVE with static IP's of, ...0.3 and ...0.30. Here is the problem:

I can ping ea. computer from one another using IP
I can ping each using computer name
I can "see" each under View Network Computers
I can see list using Net View command
I can Print using networked printer
I can MAP a drive using Net Use
(net use K: \\XPSP3\E-DRIVE)
I can then do a DIR of K:

BUT I cannot use GUI under MY Network Places to view networked computers (\\XPsp3 not accessible. Error: You might not have permission to view this resource.... Access Denied.)
I cannot use Net View \\XPSP3 for instance to view shared resources (System Error 5 - Access denied).

Guest accounts active, firewalls disabled, NetBT active on all NICs, File & Printer sharing active on all. Made sure that nodetype/dhcpnodetype not present as in Microsoft KB903267.

I'm exhausted and cannot figure this out....Can Someone please help me? Thank you!

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Run a telnet to port 139 for testing

by georgeou In reply to Networking Problem XP Pro ...

Go to the command prompt. Type:

telnet IP-of-machine-hosting-share 139

If file sharing is enabled and unobstructed, you should get a blank screen. If it times out on you and you didn't get a blank screen, that means filesharing is either disabled or something is obstructing port 139.

Remember that lots of Anti-virus software and VPN software have their own firewalls. It's not just the one built in to XP you need to worry about.

Collapse -

tried telnet...139

by dllhell In reply to Run a telnet to port 139 ...

George_ou: thank you for your reply...tried telnet 139 and this produced a blank screen. Any other suggestions?

UPDATE: Placed LMHOSTS file in all 3 machines and now able to view just the laptap from the other two machines but not able to view others from laptop nor can I access other two non-wireless from one another.

At a loss here....

Thanks in advance for any suggestions/help.

Collapse -

\\ wouldn't work?

by georgeou In reply to tried telnet...139

\\ without specifying the file share should show you something if TCP 139 is open and you've got stuff shared out. Can yu put them on the exact same LAN and then test?

Collapse -

Telnet on Port 139 "worked"

by dllhell In reply to \\ wouldn't wo ...

george_ou: at cmd prompt, I typed in:
telnet 139 and I got a blank screen, I then entered "^]" (ctrl ]) and get: Welcome to Microsoft telnet client also typed in telnet xptower 139 and received same (blank screen). If I type in ST at the telnet prompt I get: connected to xptower.

Then if I type in net view xptower at cmd prompt, I get: "System Error 5 occurred. Access is denied."

What do you mean by putting them on the exact same LAN? Both my desktops as well as my laptop are connected to Netgear Router, not using DHCP, and all have workgroup set to same, and all have IP's of 192.168.0.? and subnet of with default gateway set to router (

I have no problems connecting to internet, I even have RADMIN setup on wireless laptop to connect to one of the desktops with no problems, I can even use a printer from laptop that is connected to one of the desktops and is shared and like I stated initially, can ping using IP or computer name with no errors and if I type in just "net view" at cmd prompt, i get listing of my three computers and their respective names.

Also, just ran nMap command:
nmap -sS -p139,445 -vv

I got this result (along with other diagnostics):

139/tcp open netbios-ssn
445/tcp open microsoft-ds

I'm at a loss here.

Collapse -

Wow, I'm at a loss here too

by georgeou In reply to Telnet on Port 139 "worke ...

You can't get to file shares in either direction?

Collapse -

Resolved and thank you for all your help!

by dllhell In reply to Wow, I'm at a loss here t ...

george_ou: I feel somewhat embarrased and yet grateful for help in solving my peculiar situation. After many more hours of additional research, I found a reply in a previous thread here @ techrepublic.com in which the author suggested looking at this registry key:

hkey_local_machine\system\current control set\control\lsa -> restrictanonamous key

and changing the 1 (if present) to a 0.

Well, that has appeared to solve the problem....not sure how this registry key got set to a 1, but this has resolved the issue.

To answer your question, I could not view/access my shares in either direction.

Why this resolved the issue, i'm not sure as it looks like its just changing access via guest account? Why could I not login using a valid user name and password?
If this makes any sense.

Anyhow, I appreciate your tenacious effort in helping to correct the problem on my end.

Best regards, Scot Knox

Collapse -

Not sure how that was set

by georgeou In reply to Resolved and thank you fo ...

Was this only on a single machine screwing up access in either direction? Surely this can't be the default setting.

Collapse -

Seems like AutoPatche? may be responsible

by dllhell In reply to Resolved and thank you fo ...

george_ou: sorry for this late reply...been on vacation. Hope that u get this though:

To answer your question: "Was this only on a single machine screwing up access in either direction?"

No, all three machines I used AutoPatcher to update and apply tweaks, etc. and appears as though several tweaks was to enhance security however it appears as though it may have caused issues with my network.

Thanks again for your help.

Collapse -


by bjfails In reply to Wow, I'm at a loss here t ...

This issue may occur if the computer is configured to use p-node mode for name resolution. To determine whether a computer is configured to use p-node mode, follow these steps:

Click Start, click Run, type cmd, and then click OK.

At the command prompt, type ipconfig /all, and then press ENTER.
View the Node Type section at the start of the output. If the value that appears on the screen is Peer-Peer, the computer is running in p-node mode.
In p-node mode, the computer uses only point-to-point name queries to a Windows Internet Name Service (WINS) server. However, the WINS server is not available for NetBIOS name resolution on a peer-to-peer network.

Warning: Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this issue, follow these steps:

Click Start, click Run, type regedit, and then click OK.

Locate and then click the following registry subkey:

In the right pane of Registry Editor, delete the following values if they are present:
Note: If the NodeType value is present, this value will override the DhcpNodeType value. If neither subkey is present and if no WINS servers are configured for the client, the computer uses b-node mode. If at least one WINS server is configured, the computer uses h-node mode.

Quit Registry Editor.
Restart the computer.
Try to view workgroup computers on the network again.

Collapse -

Can ping ip but not name

by tux0r In reply to Networking Problem XP Pro ...

I have a similar problem. I am able to ping the ip, although the name will not ping. I have read many topics about this all over the net and it seems a problem for many people.

I have multiple computers with XP PRO SP2, each with different Network ID and computer names. Also have an account with same user and pass on all machines, all in same workgroup name, and a shared folder on each. I have tried every tip that I was able to dig up thru google, and still am unable to reach any shares. At the moment, each computer can only see itself and its own shares. None can see each other, but all can ping each other. One other thing about the network is, the computers all have their own internet ips. No local dhcp is in use.

I attempt to browse to an ip like:

All attempts fail, though pinging the ip works fine.

I am confused and dont know where to turn..

Related Discussions

Related Forums