Question

Locked

networking two windows 2008r2 servers with 2 nic's

By dmeagor ·
I have two servers both win2008r2 with an internet facing nic and a second nic connected direct to the other server via crossover cable.

This is the settings I have used on the direct cable connection

Server A
IP 10.10.11.10
subnet 255.255.255.0
Gateway/DNS blank

Server B
IP 10.10.11.11
subnet 255.255.255.0
Gateway/DNS blank

This config causes the network to display "Unidentified Network" but if I make the network "Private" or diable the firewall then I can ping them from the other.

Unfortunately file transfers and probably other data is still travling through the internet facing card and the direct connection doesn't seem to work.

I added the routes below to see if that would help but it didn't


Persistent Routes:
Network Address Netmask Gateway Address Metric
0.0.0.0 0.0.0.0 216.***.***.1 Default
0.0.0.0 0.0.0.0 216.***.***.1 Default
10.10.10.11 255.255.255.0 10.10.10.10 1
10.10.10.10 255.255.255.0 10.10.10.11 1

Any ideas?

This conversation is currently closed to new comments.

15 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

not a route problem, check name resolution

by Churdoo In reply to networking two windows 20 ...

if server A needs to pass IP to server B, server A will query for the IP address of server B and will proceed based on the query result, most likely the internet-facing IP.

The trick therefore is to make name resolution from either of the servers to return the PRIVATE IP's of each respective server. An entry in the HOSTS file will take precedence over most name resolution queries.

In Server A's HOSTS file (%systemroot%/system32/drivers/etc/hosts.) enter new lines:
SERVERB 10.10.11.11
SERVERB.fqdn 10.10.11.11

and in Server B's HOSTS file:
SERVERA 10.10.11.10
SERVERA.fqdn 10.10.11.10

Depending on the types of traffic, you may or may not have to make similar entries in the LMHOSTS files of each server.

Collapse -

nope, didn't make any difference.

by dmeagor In reply to not a route problem, chec ...

I added this to server A (XORMAY) and the reverse as instructed to server B (WINDRO)

127.0.0.1 localhost
::1 localhost
WINDRO 10.10.11.11
WINDRO.fqdn 10.10.11.11

Unfortunately it didn't make any difference.

Collapse -

You've almost solved it.

by dmeagor In reply to not a route problem, chec ...

I tried file copying using the IP address instead of the machine name and it used the correct card and was far faster.

Any idea why the hosts file change didn't work?

Collapse -

Probably WINS resolution defaults to "active" NIC

by TobiF In reply to You've almost solved it.

I'm afraid that the WINS resolution by defaults uses the interface where you have internet (i.e. a gateway specified).

Maybe you can override WINS by entries in the files lmhosts.

Collapse -

I guess that's my answer

by dmeagor In reply to Probably WINS resolution ...

Ok well I guess I just can't do what I had intended, thanks for the help though.

Collapse -

Wait a minute!

by TobiF In reply to I guess that's my answer

Did you ever try my last proposal?

Create a text file with the following contents:

#Test lmhosts file for local wins resolution
10.10.11.10 ServerA
10.10.11.11 ServerB

Name the file "lmhosts" (without extension) and copy it into C:\WINDOWS\System32\drivers\etc

If you already have a file namned lmhosts, then add these two entries.

Collapse -

As Tobi and I suggested, the next step is LMHOSTS file

by Churdoo In reply to You've almost solved it.

In the same directory as the HOSTS file (%systemroot%/system32/drivers/etc), look for an existing LMHOSTS. file. It may not exist by default.

NOTE: you MAY have an LMHOSTS.SAM file which is simply a sample file that you can copy to LMHOSTS. (no file extension) or you can create a new blank file.

In the LMHOSTS. file of Server A add:
SERVERB 10.10.11.11

and in SERVERB, add:
SERVERA 10.10.11.10

Collapse -

after reading all this, I wonder did the guy ever try

by CG IT In reply to As Tobi and I suggested, ...

to share a folder on one of the servers and map a network drive from the other server to the shared folder via the crossover cable?

Should work if the addressing is right even without a LM hosts file and netbios over TCP/IP. Windows 9X needs a netbios over TCP /IPhost and a hosts file for networking. W2K and upon are total TCP/IP and netbios and lmhosts files aren't needed. The server should be able to locate hosts simply by their address not machine name to address resolution.
FTP is both an application and a protocol. also, there's no way an FTP application is going to go out to the internet through a perimeter router and back in using private addressing and no domain name. The perimeter router might route the traffic but it's not going to send data with a local network address out the defaut gateway.

Collapse -

SOLVED

by dmeagor In reply to As Tobi and I suggested, ...

You were right the first time, it was the hosts file that needed to be changed.

I had previously copied your example directly without thinking but the hostname and ip were the wrong way around.

when I entered

10.10.11.11 SERVERB

it worked.

Thanks for your help!

(actually I found things are a lot easier to debug if you disable ip6 so that the ping data appears using ip4 rather than the gibberish ip6 produces.)

Collapse -

IP then servername

by Churdoo In reply to SOLVED

My bad! In HOSTS and LMHOSTS, syntax is one per line:
{ip-addr}{whitespace}{hostname or FQDN}

Sorry about the original reversal.
--C

Back to Networks Forum
15 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums