General discussion

Locked

networking XP

By hubbafixx ·
I had my XP pro in a MS Win Network LAN not long ago and i noticed that most comps runnin win2k prompted for username / password before you could access their computers through a workgroup.
For instance, I doubleclick on My Network, then on MS Windows Network, then on a wourgroup and then on an icon representing a win2k comp. Then I am prompted for name / password.
How can I make my XP pro behave in the same manner so that others who try to access my computer throught the workgroup are prompted for username and password? I know how to limit access to individual shared folders and files but I dont want it to be possible to browse which files Im sharing without valid username and password. Thankz in advance!

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

networking XP

by timwalsh In reply to networking XP

Ina peer-to-peer network (workgroup) environment, any computer hosting a shared resource is rsponsible for authenticating users accessing that resource. To do so, each computer hosting a shared resource must have user accounts for any users wishingto access that shared resource. If the user ID and password for the account setup on your computer are the same as for the account they log-on to their computer with, they will get no additional log-on prompt. The log-on prompt will only appear ifthe credentials (user ID and password) needed to access a shared resource are different from the credentials with which a user is curently logged on his computer.

Collapse -

networking XP

by hubbafixx In reply to networking XP

clear but didnt help me that much, yet good to know.

Collapse -

networking XP

by rbernados In reply to networking XP

You can only do this yourself if you have admin rights to your XP/any Windows machine from within the LAN. If you do have, try going through GPEDIT.MSC and modify the necessary items according to your specifications.. Anyway, I would also recommend to give some credit to the answer#1 for a clear and straight suggestion..

Collapse -

networking XP

by hubbafixx In reply to networking XP

I found the tihngie to edit.... just needed to remove "Everone" from it....

Collapse -

networking XP

by BeerMonster In reply to networking XP

Hi,
It sounds like you have simple file sharing enabled - this is a new feature of xp designed to make life easier (though not apparently in your case). the idea is that you can share off folders without having to give your users a username or password. In explorer, go to tools \ folder options \ view and scroll down to the 'use simple file sharing' option - if it's checked then that's your problem, so uncheck it. Hope this helps...

Collapse -

networking XP

by hubbafixx In reply to networking XP

I got simple file sharing off... #2 helped me. Had to remove "Everyone" from this thingie

Collapse -

networking XP

by lee.paxton In reply to networking XP

Go into your folder options and make sure that simple file sharing is turned on. If it's disabled, then it will enforce security on all shared files and folders.

It can be found in any folder view, under tools-folder options, then the view tab, and scroll all the way to the bottom.

Otherwise, add the user group Everyone to the security list for access to your share, that should solve it.

Collapse -

networking XP

by hubbafixx In reply to networking XP

I got simple file sharing off... #2 helped me. Had to remove "Everyone" from this thingie

Collapse -

networking XP

by hubbafixx In reply to networking XP

This question was closed by the author

Back to Windows Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums