Question

Locked

New Mac OS Leopard not connecting to Wireless Internet

By jmcallaghan ·
Hi

I've just bought a Belkin cable router to attach to a 20mb Virgin
media cable broadband.

Wireless is brilliant through our 10.4.10 MacBook. Our Windows XP
Lenove Thinkpad X61s (work PC).

However we recently purchased a MacBook Pro running 10.5.1 and it
stays connected for all of 30 seconds or so. This MacBook Pro ran
fine wirelessly with our previous Netgear system (as did the Mac Book
ad the Lenovo).

I cant see what wrong, except when I look at TCP IP on the MacBook
Pro its ip address is not in the DHCP range of the router. Instead of it
being 192.168.x.y its 169.xxx.yyy.zzz. Despite it setup for IPV4
stating its DHCP>

If I try to renew it it renews the same address.

If've tried manually assigned a 192,168.x.y+1 addresss but to no
avail.

I've tried rebooting, tried all chanels, renamed SSID and tried all
suggestios. I've contacted :
(1) apple(no help)
(2) Belkin tech support (useless),
(3) contact Virgin (expensive)


Any ideas?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

solution

by cesar In reply to New Mac OS Leopard not co ...

I FOUND A SOLUTION THAT WORKS!!!! First a little back story.

Got my Mac Blackbook and the wi-fi worked great from my Linksys wrt54g2 router. Moved to Germany and into an apartment and my connection issues started happening. My MB would connect once then loose connection quickly and would only recover connection if i either closed and re-opened my screen, or re-connected to my network... then it would drop again before my next page turn.

After multiple days of research I read about SOOOO many others having this issue and the fact the Apple pretty much refused to acknowledge the issue. It seemed that sometime near the OX 10.4.2 update the airport driver got fubar'd leaving all those with Intel based macs wi-fi connects messed up.

Some of the solutions i read about and tried had to do with changing my WEP connection to WPA. This did not work, but i left it as WPA as my research finds it a more secure connection. I also read about and tried setting my Wireless RTA Threshold in my router to 256 from the *2432 default. This as well did not work, though I have left it at this setting as it seems to be the best value for MAC's connecting over wi-fi. This is not true for PC's though so be careful.

More research, more research, o' my brain hurts and my patience is wearing..... then BINGO!!! I found a thread about connection issues that pertained to MB's not connecting to local-network printers. The poster mentioned that MAC's seem to have a hard time connecting to networks that had more than one wi-fi network present. This is my issue i thought. I have 8 in my available connections now. In my old home I had just mine. So i followed the directions suggested and it has now been 2 weeks of 100% perfect wi-fi connections.

Below is the excerpt from this page, http://www.macintouch.com/readerreports/macbookpro/topic2005.html (Do a find for ?Little Snitch?). The program the writer talks about is called Little Snitch found here, http://www.obdev.at/products/littlesnitch/index.html. It's a $29 dollar program, but in my mind its well worth it to make my $1500 Blackbook work!

This may not be the Apple Fix we have been waiting for them, but its completely working for me.


I have used Little Snitch software for several years, and it occurred to me that I might be able to use it to block any connections with the other network. Using the latest version (v.2), go to Preferences, or Little Snitch Configuration, choose Rules under the Window menu, and click the New button.

In the pop-up window that shows up, click on the gear icon and choose "Choose System Process." A file open box opens, and under the folder "libexec," choose "airportd." "airportd" is the system daemon that controls the Airport card in the MacBook Pro. In the box that comes up, set the main menu to "Allow Connections" and the Server menu to "Local Network."
Back to Desktop Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums