General discussion

Locked

New motherboard:Can't detect KB or mouse

By donaldk ·
I'm rebuilding a computer for my daughter. I installed a new power supply, new floppy drive, new 60 gig HD, and lastly; a new motherboard with AMD Athlon 2400 processor. Now, when I try to boot up to install the OS, the computer doesn't detect my keyboard or mouse, so I am unable to proceed at all and it goes to a blank screen..
Any ideas?????

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by jschein In reply to New motherboard:Can't det ...

silly question... Keyboad goes on the bottom, mouse goes on top...

If you get no video and keys are unrespnsive, something is bad... do you have a different video card or is it built in?

Do you have multiple memory sticks? Have you tried just one or the other? Are they compatible with the new board?

Any beeps?

Collapse -

by tech_wiz03 In reply to New motherboard:Can't det ...

First things first. Check all cables for correct orientation including the keyboard and mouse port. Make sure the system will 'post' beep should sound if you have speaker connected to mbo. screen should show video info at top then show mem test then show bios found info. If it gets this far it is trying to work.
If no video display at all anytime you may have onbaord video but plugged into add-on video card.
If no beeps mbo may not be powering up. (are all plugs and cards properly connected, is ram installed, is ram correct type for mbo?)
If you get get video and beeps no key you may have keyboard in wrong port connection

regards
rick

Back to Windows Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums