Question

Locked

new PS but no power

By patyan905 ·
I recently bought a new PS but after everything is plugged computer does not boot up. The LEd light on the motherboard is on but power switch does not turn on computer.
My old PS turned out to be bad since the PS switch boots up my PC rather than the power button and it will shut off and on a couple times then BIOS start up say my cpu or somthing is too low so i changed the bios to default settings and the computer starts fine and runs like it should. But now im having issues with a new PS. could it be my power button thats messed up ?

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

While it's possible

by HAL 9000 Moderator In reply to new PS but no power

It's far more likely that the BIOS Battery is flat and needs replacing if you where getting a BIOS Checksum error.

With ATX Power Supplies there should be a constant 5 V DC power feed to the M'Board so that any LED's on the M'Board are lit and more importantly the Power On switch causes a ripple on the 5 V DC Line and switches on the Computers PS to start it running.

If none of the front panel connectors have been touched it sounds as if the Power On Switch has some broken leads or the contact switch is faulty as it's not producing the necessary ripple on the 5 V DC Line. Make sure that the Soft Power On switch is connected properly and if it still doesn't work switch the reset switch over with the Power Switch and try again. If it still doesn't work I would be looking at the M'Board as the problem or something isn't connected properly. If the Old PS works the system return it to the system and run it as the new PS obviously isn't suitable for that unit or is faulty.

Col

Collapse -

maybe but...

by patyan905 In reply to While it's possible

my old PS still turns on the mobo without pushing the soft power button, and it'll reboot a couple times. The only way to turn it off is to hold the power on button a couple few for it to shut off.

The computer would boot up fine after the couple reboots and changing the CPU to default settings. it would shut off randomly a few times while Im using it.

I checked both PS with a tester and they both were fine. I tried taking the CMOS battery out, that did not work. I don't think it makes a difference since my old PS is 420w and the new one is 400w and my PC is over 4 yrs old.

Collapse -

Did you check the BIOS Battery Voltage?

by HAL 9000 Moderator In reply to maybe but...

It should be 3 Volts and needs to be there or the BIOS Settings will be lost when there is no power.

As for turning on an ATX power supply with the main Power switch this isn't at all uncommon and with many computers using Antec PS you can get them to turn on simply by plugging in a power lead with the power switch on the PS switched to on. This is because the ripple on the 5 V DC Line is misinterpret at the initial power on stage.

Testing PS with a PS Tester is next to useless as it only tells you what is going on but you need to take voltage readings while the unit is running and the PS Testers get very hot very quickly so this is a long time consuming process and impossible to do without a good Volt Meter.

I have several 24 Pin ATX PS here that are not producing any 12 V DC that you are welcome to but if you rely on a PS tester they are all working perfectly provided that you don't actually plug them into a working computer.

If the BIOS Battery is flat it not only allows the CMOS settings to disappear but it will cause all types of problems on booting and most likely will not allow the unit to boot but hang at different places in the boot process so it's very important and you need to remember that the Real Time Clock is powered by this battery so once that goes flat you can kiss good by to the RTC and having accurate Time/Date which depending on when the M'Board was made can prevent the OS from booting as the reference date Can Not be prior to critical OS Dates and this will stop the OS from booting as obviously you can not load a file that has yet to be written. You have got to remember that Computer Logic comes into play here as it will not accept as right to install something before the date stamp on it as it can not have as yet been written so you have a Logic Failure right there which stops the boot process.

Col

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums