General discussion

  • Creator
    Topic
  • #2183220

    NEWALIASES command not working

    Locked

    by net designer ·

    RHL9

    Logged-in as ROOT. After typing the “newaliases” command, I get the following error. Re-booting the server loads updated ALIASES file OK:

    hash map “Alias0”: unsafe map file /etc/aliases.db: Permission denied
    WARNING: cannot open alias database /etc/aliases
    Cannot create database for alias file /etc/aliases

All Comments

  • Author
    Replies
    • #3181739

      Reply To: NEWALIASES command not working

      by servermonkey ·

      In reply to NEWALIASES command not working

      What’s the permissions on /etc/aliases.db? It should be writable by root.

    • #3180453

      Reply To: NEWALIASES command not working

      by nico baggus ·

      In reply to NEWALIASES command not working

      Googling gave:

      https://www.redhat.com/archives/redhat-list/2003-December/msg00020.html
      Note it isn’t world readable…

      It might work to just move the .db file out of
      the way, touch the aliases file and redo a
      newaliases to create it the right way.

      kind regards,
      Nico

    • #3180352

      Reply To: NEWALIASES command not working

      by ajt74 ·

      In reply to NEWALIASES command not working

      Create text file ‘aliases’ file in /etc/mail/.

      To create the ?aliases database map?, use the following command:
      [root@]# makemap hash /etc/mail/aliases.db < /etc/mail/aliases Restart sendmail after creating aliases.db file.

    • #3179544

      Reply To: NEWALIASES command not working

      by nico baggus ·

      In reply to NEWALIASES command not working

      Your error message is now different from the
      earlier ones, ‘/etc/aliases should not be
      executable…’

      what is the ‘ls -l /etc/aliases’ for you file,
      check that with the intended bit in the article
      referenced in answer 2….?

      I bet you have some x’s in them that should not
      be there…? Just as it should not be world
      writable…

      Kind regards,
      Nico

    • #3172348

      Reply To: NEWALIASES command not working

      by net designer ·

      In reply to NEWALIASES command not working

      This question was closed by the author

Viewing 4 reply threads