Question

Locked

NIC "cable unplug" problem

By xxchubbyxx ·
I am using linksys befsr41 router as a switch.

My pc using onboard Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC, winxp sp3.

When i connect my pc to the "switch", the nic will prompt "cable unplug", but on my router the "link led" will keep "blinking".

But when i connect the pc to directly to my gateway router or another pc, everything is working.

My other pc work just fine with the "switch".

My opinion is that the "switch" detect that the nic is up, but the nic detect that the "switch" is down, judging by the "link led". BTW the leds(green and orange) at the nic did not light up.

I read on the cisco site that this problem may occur when one of the device may not have 'autonegotiate' enabled. If A enabled, B disabled, then A will show that the link is down where as B will show that the link is up.

In my case, i think the "switch" is B and pc is A. But i doubt this is the reason because all my other pc is using 'autonegotiate' and they work just fine.

Anyone have any solution to this problem?

P.S. can you tell me the real problem too if you happen to know.

Edit: I found a thread in another forum that is asking the same question as mine. same router, same nic and same problem. but there was no reply. It was posted on dec 2007. And no, it was not me.

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Possible crossover cable

by Churdoo In reply to NIC "cable unplug" proble ...

Did you say, as a test, you connect this "problem" PC directly to another PC? Presumably with the same patch cable that you're trying to use to connect to the BEFSR41? The only way this cable can connect PC to PC is if it's a crossover cable, which will explain why it doesn't work with the BEFSR41.

A Crossover cable is one in which pins 1/2 on one end, the Orange pair, map to pins 3/6 on the other, and likewise with pins 3/6 (green) to 1/2. These are used for connecting PC to PC or switch to switch (a lot of switches today automatically detect cable type and will swap internally as needed -- though the BEFSR41 does not do this).

Swap the cable with a known good (straight-through) patch cable and test. Post back any other findings.

Collapse -

re:Possible crossover cable

by xxchubbyxx In reply to Possible crossover cable

i am using cat5e(also tried cat5) straight thru cable for all connection mentioned.

fyi, the newer nic are able to communicate pc-pc using striaght thru cable.

Collapse -

If you have had this pc connected to another pc....

by ThumbsUp2 In reply to re:Possible crossover cab ...

Have you tried using the Network Setup Wizard? That pc may be still thinking it's connected through another pc. Let the Wizard correct the problem.

Collapse -

re:If you have had this pc connected to another pc....

by xxchubbyxx In reply to If you have had this pc c ...

ya i did, but it diddnt work either.

Collapse -

I have a similar issue at work

by w2ktechman In reply to NIC "cable unplug" proble ...

however the disconnect never really is disconnected, just an annoying error box.

It started when I put in an old switch to run setups from. It has continued for several years now. It still works for me so I use it.

Anyway, it may be the switch/router

Collapse -

re: I have a similar issue at work

by xxchubbyxx In reply to I have a similar issue at ...

For my case there is totally no connectivity.

I did include the possibility that it could be the problem with the router, but i did manage to get connection once.

Here is how it happen:

I thought it might be something to do with winxp sp3, so i reformat it with winxp sp1. But the problem is still there, so i went to look for solution on the net using another pc while leaving it on.

About an hour later, my bro told me that suddenly it worked. I check on all the settings, it was the same. It was working even after several reboot.

No one touched the pc and it suddenly work for unknown reasons. So i decided to give sp3 a shot, and the problem comes back.

I tried sp1 again and it did not work. Left it on for a couple of hours and still did not work.

Collapse -

Sounds like faulty switch to me.

Get another one to test out.

Please post back if you have any more problems or questions.

Collapse -

Is there another port on the

by w2ktechman In reply to re: I have a similar issu ...

switch/router to try? If so, try it! is it working?
Also, you may need to update the NIC drivers depending on the service pack. In the past I have run into this issue with some HW.
Also, replace the LAN cable and test it with a different cable.

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums