General discussion

Locked

NIC will not take DHCP address

By stuchele ·
Running win2k with 3COM NIC and it will not take a DHCP address from my Linksys router. However I can assign a static IP address and it works fine. I was able to ping the NIC as well as take remote control of the PC using VNC. I have changed out the NIC and had different problems, like the NIC did not appear in the device manager. It is possible that the PCI slot is bad??? I am not sure, I tried different slots same problem.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Roy Penfold In reply to NIC will not take DHCP ad ...

Have you tried changing the mac address of the nic by one number (Open your NIC's properties/configuration page found in Network Neighborhood/My Network Places (depending on OS), or through Device Manager. Click on the Advanced tab and you will see an option to put in an Administrative Address).

It could be as simple as a bad mac.

Collapse -

by josh In reply to NIC will not take DHCP ad ...

You may want to rebuild your TCP/IP firstly, you can do that with winsockfix...
http://www.eternalisp.com/patches/WinsockFix.exe

I would try a different port on your router and another cable. You may want to test the current cable as it is and see if there is a short or possible miswire (i have seen cables work even though the testing on them failed)...You may also want to check your NIC properties in device manager, and see if any settings are different from default. (example: force 10MB half duplex, force 100MB Full duplex, Auto Negotiate) Which of course in that exmpl you would want your setting to me AutoNegotiate.
Hope that helps, post back!

Collapse -

by stuchele In reply to

Poster rated this answer.

Collapse -

by stuchele In reply to NIC will not take DHCP ad ...

This question was closed by the author

Back to Desktop Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums