Question

Locked

No audio device

By abanerji ·
My system is Compaq Evo D380mx, P4 1.66, Intel 845g, 512MB RAM, integrated AC97 audio, XP-pro SP2, WMP10. The other details from Everest scan (done when system was ok) are :-
Audio Adapter Intel 82801DB ICH4 - AC'97 Audio Controller [A-1]
Audio Controller Type Intel 82801DB(M) ICH4
Codec Name SigmaTel STAC9750/51
Codec ID 83847650h
S/PDIF Output Supported
Device Description SigmaTel Audio
Driver Module STAC97.sys
Driver Description SigmaTel C-Major Audio
Driver Date 02-26-02
Driver Version 5.10.0.3630
Driver Provider SigmaTel
INF File oem4.inf
Hardware ID PCI\VEN_8086&DEV_24C5&SUBSYS_0511147B&REV_01
Location Information PCI bus 0, device 31, function 5

So far (last five years) audio has played smooth. Just had to replace the heatsink fan ... got a technician to do it. After that windows sounds (start / shutdown) did play, and I did not check any music. Later, WMP refused to play music. Device manager shows all ok, but control panel > sound properties > volume says "no audio device". Now, even the windows sounds are not coming.

Thanks for help.

=============================================

Additional information here : I ran Everest again. I am pasting below extracts from earlier scan (in early 2007) and now, side-by-side. Shall be grateful for guidance.

==================================================

Earlier : Audio Adapter Intel 82801DB ICH4 - AC'97 Audio Controller [A-1]

Now : Audio Adapter Modem #2 Line Playback

--------------------------------------------------------------------------

Earlier : [ South Bridge: Intel 82801DB ICH4 ]
AC'97 Audio Controller:
Audio Controller Type Intel 82801DB(M) ICH4
Codec Name SigmaTel STAC9750/51
Codec ID 83847650h
S/PDIF Output Supported

Now : [ South Bridge: Intel 82801DB ICH4 ]
Audio section missing

--------------------------------------------------------------------------

Earlier : Windows Audio
Device Identifier Device Description
midi-in.0 0001 0067 MPU-401
midi-out.0 0001 0066 Microsoft GS Wavetable SW Synth
midi-out.1 0001 0066 MPU-401
mixer.0 0001 0068 SigmaTel Audio
wave-in.0 0001 0065 SigmaTel Audio
wave-in.1 0001 0050 Modem #1 Line Record
wave-out.0 0001 0064 SigmaTel Audio
wave-out.1 0001 0051 Modem #1 Line Playback

Now : Windows Audio
Device Identifier Device Description
midi-in.0 0001 0067 MPU-401
midi-out.0 0001 0066 MPU-401
wave-in.0 0001 0050 Modem #2 Line Record
wave-out.0 0001 0051 Modem #2 Line Playback

--------------------------------------------------------------------------

Earler : PCI / PnP Audio
Device Description Type
Intel 82801DB ICH4 - AC'97 Audio Controller [A-1] PCI

Now : PCI / PnP Audio section missing

--------------------------------------------------------------------------

Earlier : [ SigmaTel Audio ]
DirectSound Device Properties:
Device Description SigmaTel Audio
Driver Module STAC97.sys

Now : [ SigmaTel Audio ] section missing

--------------------------------------------------------------------------

Earlier : PCI Devices (included)
Bus 0, Device 31, Function 5 Intel 82801DB ICH4 - AC'97 Audio Controller [A-1]

Now : PCI Devices (includes)
Above line missing

--------------------------------------------------------------------------

Earlier : Device Resources (included)
Resource Share Device Description
IRQ 17 Shared SigmaTel C-Major Audio

Now : Device Resources (includes)
Above line missing

This conversation is currently closed to new comments.

0 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Share your knowledge
Back to Hardware Forum
0 total posts (Page 1 of 1)  

Related Forums