Question

Locked

No display on monitor

By yoginc ·
Hi.I purchased a new pc a year ago and it uses RAID(level 1).Just a month back,one of the hard disks failed and i installed a new one.I managed to rebuild all data from the 1st hard drive to the new one using intel matrix manager software.Only yesterday when trying to shut down the pc it got stuck in the process on the shut down screen.I waited for almost 1/2 hr but it wouldn't turn off,so i switched off the mains.Later when i tried to restart my pc,i wouldn't get a display on the monitor.The cpu,fans,and gpu are running but somehow the system doesn't boot.Also i dont get the usual beep sound when i switch on the pc.I also checked the motherboard.a green LED on it powers on when running but there's no response from the red LED(which usually switches on).It just blinks once and stays off.Does anyone have a solution?

PS: i have an intel dq45cb motherboard with a core2duo processor(E7400),ATI HD 4650 graphic card(pci) and 4 gb of ram using 2gb modules.

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Try unplugging the mains/power lead

by OH Smeg In reply to No display on monitor

Then pressing the power button for 30 or so seconds with the mains/power lead removed.

Then plug the Mains Lead back in and try turning on now. If it starts now the Capacitors in the Power Supply are failing and the PS needs replacing.

Col

Collapse -

still nothing

by yoginc In reply to Try unplugging the mains/ ...

I tried that...Now when i switch on the mains all that happens is that the green LED on the mobo glows..the fans and all start only when i switch on the power button on the front panel.No POST,no beeps,nothing.Infact,from what i know, with no memory sticks i should get at least some beeps of indication.I do not even get those without any memory.You think the motherboard or maybe the processor has a problem/

Collapse -

My first option is always the Power Supply

by OH Smeg In reply to still nothing

I would replace it with a Known Good one or at least plug in a Known Good Power Supply to test the M'Board and so on with. You only need to plug in the M'Board not the HDD and any other Electrical devices that are connected to the M'Board.

I've lost count of the number of clients who want to jump straight to replacing the M'Board and then when that doesn't fix anything they replace everything except the Power Supply in the case with the same result.

Anyway plug in a Known Good Power Supply you need to know that it works before doing this and then if the system doesn't start with that PS in it refit it to the system that it came out of to make sure that it was not damaged by the M'Board that it was plugged into.

If the system still doesn't work with a Known Good Power Supply and that Known Good Power Supply still works another system you can then look at replacing the M'Board. Naturally if the PS fails to work in the system that it came out of you know straight away that you have a M'Board problem.

Col
Edited to add That is the ATX Plug on the M'Board that needs plugging in and the Supplementary 12 V DC Plug. You don't need to plug anything else in to test the M'Board, CPU and so on. Though if the Video Card has it's own Power Plug that should be plugged in as the Video Card will attempt to draw too much current through the M'Board and could damage both the Video Card and M'Board.

Collapse -

Tried to check voltage readings

by yoginc In reply to My first option is always ...

Well i did try to check the voltage readings of the pins on the power cord with a DMM.I was surprised to get no readings on any pin at all(i hope i did it the right way).but if it does show no voltage readings then how come the system powers on with the power switch(though it doesn't when u switch on the mains,that only happens after the power switch).And plus i've got no other systems or PSUs which i can use for testing

Collapse -

There are several different voltages produced by the PS

by OH Smeg In reply to Tried to check voltage re ...

The main ones are 3 V DC 5 V DC and 12 V DC.

But you can have voltage present but little to no current so things like Fans will start to twitch or maybe even spin but there isn't enough current to power the CPU.

But having fans spin only means that there is 12 V DC Present nothing about the 3 V or the 5 V DC is indicated. Also a Static Test of the Power Supply with a DMM is just that and doesn't imply that it's working or not.

As you don't have another system to rob a PS from you'll have to try a new one. Not an ideal test but it's cheaper and better than replacing M'Boards.

Col

Collapse -

just found out something

by yoginc In reply to There are several differe ...

I had a look at the power cord today and just noticed that the wire from pin 18(-5V) is completely missing.I dont know but even i realized this today,for the first time apparently,after having a look.I was quite surprised as it was the only wire not where it was supposed to be.Is that wire important for proper functioning?because after all this time of wondering what the problem might be i just happened to glance at an empty pin slot in the cord and wondered if it had something to do with that?

Collapse -

pin18 removed from atx specification

by Rendol In reply to just found out something

18 -5V White -5 VDC (2002 v1.2 made optional, 2004 v2.01 removed from specification)

Collapse -

Re: No display on monitor

by prrethish In reply to No display on monitor

Just remove u r ram clean & re-fix it

Collapse -

Verify startup procedure

by Rendol In reply to No display on monitor

First, unplug power and any other voltage feedback cords (USB, monitor) to avoid MoBo damage. Then unplug all non-critical perepherial (mouse but not the keyboard, audio, etc.) and drives (hdd, fdd, cd/dvd) both power and data. Remove memory cards from PC. Plug only critical cords (power, monitor, keyboard if unplugged) and try to startup your PC. If it's OK, POST No_Memory beeps shoud appered. If not - you might have motherbaord problem. Also, try to clear CMOS settings and check lithium battery voltage.

Collapse -

Tried that

by yoginc In reply to Verify startup procedure

I already tried all that you mentioned but i did not get the desired results.The only thing i didn't try is check the the cmos battery.If still nothing happens after that then it must be a mobo problem as u say.I checked power cord voltages and they all seemed fine...but the thing that hints a mobo problem is the fact that i get no beeps what-so-ever even when i've disconnected all memory cards from the mobo.
By the way,what should be the optimum voltage on the lithium battery if i have to measure it?Just asking because i've never really checked it before

Back to Hardware Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums