Question

Locked

NO drivers for ASUS wifi-g NIC for Vista x64?!

By roise4000 ·
hi, i am having problems finding drivers for my wifi-g NIC card that came with the A8V Deluxe motherboard i bought a while ago... i have been using it fine with the drivers that came with it in a disc, but now that i moved to vista, the drivers wont work anymore (reasonable). I am having hard time locating drivers for that wireless NIC. and i dont know the model of the thing, because in the device manager in my XP it just states wireless G device, and on the disc itself just says "54mbps IEEE802.11g wireless LAN PCI Card Rev.79.02" there is also this red label: "M438"
serail number on the card itself: 52MG0C8788
i know that the chipset is ralink, but thats it

pls help , thanks

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

give this a try

by .Martin. In reply to NO drivers for ASUS wifi- ...

try the driver detector at http://tinyurl.com/ay8j3v

Collapse -

Also

by boxfiddler Moderator In reply to NO drivers for ASUS wifi- ...

give Belarc a shot. It should identify all your hardware...

http://www.belarc.com/free_download.html

Collapse -

none worked

by roise4000 In reply to NO drivers for ASUS wifi- ...

the first app told me that everything was fine with my current driver, but found a bounch of other errors :)
the second app told me many things about the current sys but exactly about the wireless NIC driver: told me: none detected :)

I didnt explain my problem very well. i already use ralink drivers downloaded from their site. drivers for the 2500 chipset model, but they were randomly selected by me. i am not sure if that is the correct driver. my nic works i guess but crippled. When i run bitcomet, instantaneously my adapter dies. i ran some test with other computers and IT IS my NIC. the same computer running under XP doesnt have that problem. ? any ideas?

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums