General discussion

Locked

No password - Directory Services Restore

By Gav@Melbourne ·
I'm running Windows 2000 server, with the Active Directory database running on a second harddrive which has failed.

On bootup, I receive a LSASS.exe error (Directory services could not start). I reboot, hit F8 go into Directory Services Restore Mode.

However, I do not have the administrator password for the directory services restore. This password is obviously stored locally and is different to my admin account which is stored in Active Directory (on the failed disk).

How can I (a) get back into my machine and (b) fix AD?

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by ewgny In reply to No password - Directory S ...

The administrator account for directory restore is the original administrator account from when the server was originally setup ( the old local administrator account) If you have no record of it you can use ERD Commander from Winternals to reset the password on the Administrator account
using the locksmith utility.
http://tinyurl.com/2fkdq

Collapse -

by Gav@Melbourne In reply to

From what I could establish the Directory sercvices restore password is set when the server is made a domain controller (dcpromo). At the time though I don't recall ever having to put a new one in.

Collapse -

by briantruitt In reply to No password - Directory S ...

You can try using a Linux based password resetter like this one, http://home.eunet.no/~pnordahl/ntpasswd/bootdisk.html, (I guess take out spaces if there are any). I had to use it the other day to reset the Admin password on a pc that had just been removed from a domain and didn't have a local admin password or at least no one here knew it. Worked like a charm.

Collapse -

by Gav@Melbourne In reply to

Had a similar thought myself. After messing around a bit last night with a bootable registry editor I've found that the local SAM datatbase is "not present". Also tried tweaking to remove the admin password step for the recovery console without success.

Thanks for the input. Looks like I might have to do an o/s rebuild - fortunately I have seperately partitioned apps and data :)

Collapse -

by Gav@Melbourne In reply to No password - Directory S ...

This question was closed by the author

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums