No Picture from New Built PC?

By Trikon ·
So I built my own PC, all the parts I go were compatible with each other. I would plug in my computer to the monitor and power it on, but I got no picture. I tried swapping ram sticks still got nothing. Al the fans spin on the power supply, case, processor and the hard drive sounds like it is running.

I called Gigabyte, the creators of the motherboard and they said to exchange the motherboard. I did.

But now I'm getting the same problem. My bios won't come up and no picture? Is it possible the processor was DOA? My motherboard and case both DON'T have a built in speaker. Is there anyway to know for sure?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Gigabyte M'Boards have a Header Strip

by OH Smeg Moderator In reply to No Picture from New Built ...

To connect the Front Panel Plugs to so plug a Speaker to the Designated Pins of that Header Strip and see what if anything happens.

As far as Compatible Parts are concerned what makes you think that the M'Board Chip Set is Compatible with the Video Card Chip Set?

I've had cases where the same chip Set on a Video Card from different makers work differently In one case the thing didn't work but in another the same Chip Set from a Different Video Card Maker did work.

Also it's possible that the CPU is not correctly inserted in the Socket I've seen this quite a lot with the Intel 775 and newer Sockets. The Home Builder gets the CPU Fitting wrong and the CPU is not working so nothing works?

Also did you test the M'Board before fitting to the case?

I've seen cases where incorrect mounting in the case has caused the Video Card not to fit all of the way into the Socket on the M'Board and hence people think that the thing isn't working when all that has happened is that the Video Card is not correctly plugged in.

You can lay the M'Board on White Paper on a desk and plug in the CPU, RAM and Video Card as well as a Power Supply to test before fitting to a case. If it doesn't work then you don't waste time & effort fitting to the case and if it does work then and not after being fitted to the case you know that you've done something wrong putting it into the case.

Also what type of crappy case doesn't have a speaker? Also have you got a part way decent Power Supply of just a cheap No Name one that comes in a even cheaper No Name case?

If the Video Card has a Power Connector on it have you plugged this into the Power Supply?


Collapse -


by Trikon In reply to No Picture from New Built ...

Motherboard has a built in video card. Tested with the built in one and the external one, same result. My bios should be coming up, but I get nothing

Antec 3 hundred versatile mini tower, which isn't really mini or crappy....

700W MoDXStream-Pro power supply.

Processor is AMD A8, not Intel.

A75-UD4H Motherboard.

Collapse -

Well assuming that the CPU is on the Gigabyte Supported CPU List

by OH Smeg Moderator In reply to No Picture from New Built ...

It should be one of these

AMD A8-3850 2900MHz 1MBx4 N/A Llano 32nm B0 100W F2
AMD A8-3800 2400MHz 1MBx4 N/A Llano 32nm B0 65W F2

Is it?

Look in the Gigabyte Manual and see if the BIOS Clear Jumper is set to Clear and not run and reset it to Run.

Not a common thing with Gigabyte M'Boards but some resellers set these to Clear to prolong the Battery Life so you should check.

You'll need to connect a speaker you can get a Pizeo Electric One from a Electronics store and connect to the Header Strip listed in the Gigabyte Manual to find out what is happening here. If you no longer have the manual you can download one from here and incidentally all Gigabyte M'Boards start with the GA Prefix if you do not list GA A75-UD4H you are not giving the proper Gigabyte Model Number.

Also check the RAM you have used against the Gigabyte RAM Support List here

If you are not using RAM from this list that could very well be your problem but if you are the full specifications for this M'Board are listed here

And you are going to need to remove the M'Board from the case remove the CPU and check the legs on it for any bent legs and straighten as necessary and then refit in the correct orientation to the CPU Socket then fit the Heatsink to the M'Board.

The Heatsink Thermal Transfer Pad should have part way melted onto the CPU if it hasn't either there is no power to the CPU or the CPU is incorrectly set in the socket. It's as simple as that.

If it still doesn't work you'll need to remove the M'Board from the case lay it on some clean white paper plug in the Power Supply to both the 24 Pin ATX Connector and the 8 Pin Auxiliary Connector. If your Power Supply doesn't have a 8 Pin Plug for the Auxiliary Connector you need a different Power Supply as this supplies the 12 V DC to various parts of the M'Board that are not supplied by the 24 Pin ATX Socket.

Connect a Pizeo Electric Speaker to the 2 Header Pins on the Front Panel Connector and remove all but the CPU and Power Supply. Then short out the 2 pins for the Power On Front Panel Switch with either a screwdriver or plug on a press On Contact Switch and start the system running. If it runs you should hear a series of beeps from the Speaker and the M'Board Manual will tell you what those beeps mean.

No Beeps means no power to necessary parts of the M'Board and this could very easily be a faulty Power Supply which is supplying 12 V DC but not the 5 or 1.3 V DC or even if it has those voltages present there may be no where near enough current available to run the system. Or that the CPU is in the wrong way, the Heat Sink is not making proper contact with the CPU and the CPU has burnt out. This can happen in under a second if the Heatsink is incorrectly fitted.

Also having fans run says is that there is 12 V DC present at enough current to run them. It in no way implies that any of the other Power Rails are present or have sufficient current available to run the system.

You'll need a way to test the PS here and Antec make a excellent little unit shown here to do this

So you could get one of those or fit the PS you are currently using to another working computer and see if it powers that system. If it doesn't you need a replacement Power Supply. Personally I only use Antec Power Supplies like Earthworks or Basiq types as I have had excellent protection to the electronics inside the case offered by these at a reasonable price. But that's just me and I have not had any real issues with these units not working from new but it is vitally important to get a suitable type PS for the case that you have purchased.

If it works out of the case plug in a monitor and again test this on another working computer it wouldn't be the first time that I wasted hours trying to fault find a issue when the monitor had died overnight or from the last job that I used it on minutes previously.

That should give you something to start with but I have to warn you I do not use AMD CPU's because I have found them way to Finicky in the past to be good enough for my customers. I have pulled several High End Servers out of Service because the buyer wanted AMD Options which simply didn't fit the required use where as Dual or Quad Xeon Systems worked faultlessly in the exact same location.


Collapse -

No Picture from New Built PC

Well I know this is going to sound stupid, but make sure the power to the monitor is turned on, which I'm sure it is. Second are you able to try that monitor on another known working system? At least this way you can make sure that the monitor is indeed working.
Once you know the monitor is working, I would then work my way to make sure VGA or DVI cable is good. Yes I know this is elementary but at least this way you know for sure it's not the monitor or the cables. When it boots up do you hear any beeps or tones? You do have a HDD in it correct? I just went back and read your post, I see there is no speakers so you wouldn't know if it beeps or tones. Because if you're not hearing any beeps that means there's no power getting to the mobo. I would at least try switching out the power supply and go from there. There's gotta be something there that's causing it, it's just going to take some more digging into. Try that and let us know.

Related Discussions

Related Forums