No power to laptop! Could it be a bad motherboard?

By travis.sirmon ·
HP Pavilion zv6000
I have an hp pavilion zv6000 that is giving me problems. When I plug it in the blue power light(lightning bolt) blinks pretty fast off and on. I can hear ticking around the area where the power cord is. Nothing else happens. cant get it to start at all. No sound of fan or anything.
I have taken the laptop apart and found no burnt or smelly areas of the motherboard or other parts. I have wiggled the power cord, unplugged it and tried just the battery. I got the same clicking only more quiet then with the cord plugged in. I have tried without the battery in and same deal.
Anyone have any idea what the problem could be? WOuld hate to have to buy a new motherboard and the laptop is just over a year old and just out of warranty of course.
THanks all

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Same Power problem

by photofun1 In reply to No power to laptop! Could ...

I Have a Dell which lost all power. The first thing a tried was, replace the power cable. A new one from Dell. That did not work. Next I checked the amount of electriocity getting to the cpu's power supply from the wall oulet (via the power cable/transformer)using a voltagemeter. I discovered there was not enough power getting to the motherboard from the power supply. It turned out to be a Diode. Which I hate to tell you means the motherboard needs to be replaced. The sound you are hearing, could be the cpu's power supply fa, if it has pne. If not I would not turn on the system until it is checked. I hope this gives you some idea. Its very possible it is just the cord itself.

Back to Hardware Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums