General discussion

Locked

not able to map user's personal directory

By nvasquez ·
I have a 5.1 sp 6, my workstation is an xp, my client is the 4.9 sp1a. the loging script reads map root g:=%home_directory
i keep getting "LOGIN-LGNWNT32.DLL-400: A network drive cannot be mapped to a drive
that is designated as a local drive" I changed the first nework letter in the nw properties, i changed from letter "g" to "u" and i get "LOGIN-LGNWNT32.DLL-430: The following drive mapping operation could not be completed. The error code was 8804" I tried deleting the volume through console 1 and recreated again by running dsrepair. I tried different switches instead of %home_directory i replaced it with %cn or %1 and many other things. does anyone know a solution to this????

thank you.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by pierrejamme In reply to not able to map user's pe ...

Number one item is to make sure the user has rights to their Home directory. Right mouse on the user in nwadmn32 and select Environment. you will see Home directory at the bottom, give them Supervisor.

I have been using the following for years for mapping of Home with no problem, unless someone deletes their Home directroy. (Just Happened)

SET MAPROOTOFF="1"

MAP INS S1:=servername/SYS:\LOGIN
MAP INS S2:=servername/SYS:\PUBLIC
MAP F:=\\servername\SYS\
MAP H:=%HOME_DIRECTORY

Error 8804 means trouble with corruption, see:
http://support.novell.com/cgi-bin/search/searchtid.cgi?/10064391.htm


Good Luck

Collapse -

by krkosiorek In reply to not able to map user's pe ...

Do you have the Home Directory (volume and path) defined under Environment (NWADMN) for the user that gets this error?

Also, is the Home Directory (the actual folder) name the same as the user's login ID? If so, you can use the %LOGIN_NAME in the login script to map to the folder. This eliminates the need to set the Home Directory information.

Ex:
MAP ROOT Z:=<full volume context>:%LOGIN_NAME

Hope this helps.

Collapse -

by kwyrick In reply to not able to map user's pe ...

It sounds like the users home folder isn't defined in the user profiles. In Nwadmin, select the user properties, select the enviroment tab and make sure their home folder is defined. Make sure the user has rights to the directory. I suggest everything but Supervisor and Administrator. That should resolve the issue.

Collapse -

by andypiesse In reply to not able to map user's pe ...

just a minor point but in your question %home_directory is in lowercase does this imply that it is in lowercase in your script. If so I think it has to be in uppercase

Collapse -

by kcrabb In reply to not able to map user's pe ...

One more thing that you might check. See if the user can go to the folder via network neighborhood. If they can see the file then they have the correct rights, etc. If that is the case it maybe that the users name is longer then the set value for folder length on the server. We had a few servers that the max length was set and we would have to go shorten the file name for their home area. Then reassign rights to this directory.

Hope this helps.

Collapse -

by roemere In reply to not able to map user's pe ...

On our system (NW 5.1 sp6) We had one Win2K user who had this problem after upgrading to client 4.9 sp2....the line below proved to be the problem:

MAP ROOT H:=SERVER_DATA:USERS\/OFFICE

Removing the forward slash before OFFICE solved the problem. The corrected line is:

MAP ROOT H:=SERVER_DATA:USERS\OFFICE

Surprisingly, this typo had not caused any problems with previous versions of the client.

Collapse -

by VE7YME In reply to not able to map user's pe ...

You might want to check that the User ID and their home directory are not longer thatn 8 characters long. We found that on some servers the longer names were not accepted.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums