General discussion

Locked

Not booting after raid cont replacement

By Andrew Cooke ·
Hi.. Here's the problem

1) You perform a cold backup using veritas of a Win2k server.
2) You install Win2k and veritas on a new server with different hardware.
3) You perform a complete restore on new server
4) Server no longer boots because of the different raid controller drivers.

Now I have been searching the 'net and found a MS technote that explains how to change a raid controller driver using registry editors and ERD disks. This was tried several times without sucess.

Any ways forward.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to Not booting after raid co ...

tell us more...what are your no boot symptoms...how far along do you figure you are getting...is it making it to boot.ini and then failing? (i believe the symptom of this is hung at a blinking curser...)
what have we got to work with? does old system still run? can you get another hard drive in the new server, install Win2k server on that, use it to look at, manipulate the installation on the RAID array...examimine the old boot.ini file maybe...

Collapse -

by CG IT In reply to Not booting after raid co ...

St. Schultz has most of the best questions already asked!

where is the bott.ini? Did you check your BIOS to ensure somewhere in the boot order the RAID array is chosen? Depending upon your mainboard make, model, the BIOS will either show you the detected RAID array and allow you to choose it as a bootable drive OR you may have to enable "boot SCSI" if the BIOS does not list the RAID array [this is true on certain MSI boards with Promise Serial ATA].

Collapse -

by CG IT In reply to

thanks for your additional info. note: you've answered your own question.

Collapse -

by Andrew Cooke In reply to Not booting after raid co ...

Thanks for the extra questions.

It is not a BIOS or a boot.ini thing. I get a blue screen when it tries to load the raid controller drivers, which is during the famous

Loading Windows 2000
........

Its a bit like this, during a blank install of Win2k if I don't press F6 to install the additional drivers the computer cannot see the disks.

So in my situation I have a working Win2k OS installed, all raid arrays are setup the same as original server (note: very simple config).

The working system is using the correct drivers that I gave it during install. By me performing a complete recovery from another machine old server it overides the entire new servers setup. So the registry has references to the old raid controller drivers.

Hence after a reboot when it get to the part of loading the drivers in order to continue with loading the OS it fails because it tries to use an old controller driver. The disks therefore cannot be seen by the OS and it does not boot.

Microsoft recomend installing the new raid controller drivers on the existing server before performing this type of operation. This way the server should still boot it will just get an error when it tries to load the old raid driver.

Collapse -

by Andrew Cooke In reply to Not booting after raid co ...

The last comment says

"I've answered my own question"

the point was none of the extra info I mentioned worked.... hence the reason for telling you what I've already tested

Collapse -

by Monice In reply to Not booting after raid co ...

I had the same issues on a Compaq server about a month ago at a client site. The raid controller died and we installed a newer one. Of course the server blue screened when loading drivers. What I ended up having to do is install an older raid controller that uses the same driver version as the failed one, leave the new one installed also, connecting the drives to the older controller, boot into the os and install the drivers for the new controller. Shut down the server, remove the unwanted controller, connect the drives to the new controller and presto up and running.

Hope this helps.

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums