General discussion


NT 4 - Logon Scripts

By TomSal ·
This driving me a bit crazy because I've done another script using this method and it worked fine (I've since removed that script) and yet this one doesn't work.

The problem is this...I've created an incredibly simple one line script that makes use of the NET USE command to create a drive share on server that is on the same domain as the PDC.

Just as text books have it I dropped my 1kb "XDRIVE.BAT" file in the C:\Winnt\System32\Repl\Import\Scripts location.

Through user profiles optionof the User Manager for Domains feature I typed in XDRIVE.BAT as the logon script to execute.

I'm not using system policies at the moment..there are no home directories either.

Not that any of that should matter, but just proving how simple the setup is right now.

This is a new server that just took over as PDC, if that has anything to do with anything.

I don't see how though, since it views the NETBIOS names correctly and has no problem browsing or sending files accross the network to ANY of our servers.

I'm totally doing this on the experience of how I've done my last script , which let me remind everyone, worked fine.

So why isn't this one working?

Btw, when you test the script find (execute the .bat file locally) it works like it should and creates the drive share. Its just not executing when a user logs on to the domain.

Its nerve wracking, because I know I've done the same procedure before on our OLD NT 3.51 PDC and it worked first time through.

I even double checked that I'm following protocol with where I saved my .bat file and how I entered it in the user account...everything is in line with what Microsoft help suggests.

Any advice?

Btw, the point of the script is to create a shared drive connection on each users system so they have a network backup point to dump certain files to.


This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Security issue?

by <--- Due West In reply to NT 4 - Logon Scripts

Hi Tom,

Have you checked that the file has the proper security levels set for the users/groups logging in?
I'm assuming you've put the bat file in the ...repl\scripts\import directory on the PDC Server... :)
Right click the file and check the permissions in properties...
Also, does the script run from the user's workstation AFTER they've successfully logged in? That is; can you go via network neighbourhood to the server's NETLOGON share and "see" and "run" the script file? IF not, it's a permissions issue, if you can, it may be down to the Rights assigned in the User Mananager on the Server...

Let me know how you go...



Collapse -

maybe the answer

by sandi In reply to NT 4 - Logon Scripts

I had one like this too. What I had to do is re-install the resource kit and last service pack. Once the resource kit and service pack was re-installed, the script ran properly when the client logged in.

Collapse -

One more thing...

by je27 In reply to NT 4 - Logon Scripts

I think Due West is on the right track, but you should also check to make sure that the import\scripts is shared as NETLOGON. I've seen the export\scripts folder being used as the NETLOGON share instead, and of course if your script isn't there it won't run. I've also seen cases where the NETLOGON share has changed from the import folder to the export folder without any user interaction, so just because it was shared correctly at one time doesn't mean it still is. Hope this helps.

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums