General discussion

Locked

NT Policy Problem

By bbuechler ·
We have a policy that restricts users to a custom start menu, and removes all ability to see any desktop icons, and no access to the control panel. In Policy Editor, the only option to restrict access to Control panel is to "Display" or not "display" the control panel. There is no apparent ability to allow access to some control panel items and not others.

The Problem I'm having is, I need users to be able to access the Printers Folder, and nothing else.

If I put the printers folder in the custom start menu, while still hiding the control panel, it doesn't allow the user access.

Please provide me a solution so that the users are unable to access display settings, and all of that, but still be able to manipulate printers. Thanks.

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

NT Policy Problem

by Gregory W. Smith In reply to NT Policy Problem

The default policy templates will allow you to restrict the "Display" applet in Control Panel, while having access to whatever other applets you do not disable.

Not all applets can be disabled using the default templates, however.

So if you restrict the Display applet and enable Control Panel, that would meet your stated goals :)

Collapse -

NT Policy Problem

by bbuechler In reply to NT Policy Problem

Was on the right track with this, but ran into problems with Policy configurations.

Collapse -

NT Policy Problem

by ARWJnPlanoTX In reply to NT Policy Problem

Hi,
Open Control Panel so you can see the desktop. Drag the 'Printers' icon to the desktop. It will ask you if you would like to create a shortcut. Click yes. You can then put this shortcut any where you want (Start Menu, Desktop, etc.).

Good luck,
Al

Collapse -

NT Policy Problem

by bbuechler In reply to NT Policy Problem

Tried that already with no success.

Collapse -

NT Policy Problem

by DC1 In reply to NT Policy Problem

Using regedit, search through the registry for printers. The folder should be under HKCR\CLSID\{long number}. Right click the folder and choose copy key name. Right click on the users desktop and select new folder. Rename new folder printers. and then paste the key name to the end of the printers. Next choose to rename the folder to printers.{long number}. That is you will remove the HKCR\CLSID\ from the key name. After you do this the folder will change it icon to the printers folder and you will be able to manipulate your printers.

Collapse -

NT Policy Problem

by bbuechler In reply to NT Policy Problem

Beautiful man! Works like a charm! The instructions were a bit difficult to understand, but once I figured out what you were talking about, it works perfectly. Thanks.

Back to Windows Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums