General discussion

Locked

NT Service Database Lock

By firesheep43 ·
I am fighting with a nasty high end NT 4.0 WS used for video editing. The problem is with RAS & TCP/IP protocol. They do not work - no messages, just unresponsive. When trying to remove RAS & TCP/IP, I get the error message that the Service Database is locked, then the machine locks. Any suggestions on how to get around this? I do not know a lot of the history, but the user had contacted the system builder's tech support and they had them delete several files (unknown at this point), install sp6a and attempt to use the ERD (it was never updated...) but according to the user, this just made more problems.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

NT Service Database Lock

by kkiedrowski In reply to NT Service Database Lock

I have had a serives Databsae lock before. The problem I had what that there was a TCP/IP conflict on the network. Are you using WINS and DHCP?
Does this macine have only one nic? I had to unbind wins from the nic attaching to the internal network.
So unbind everything except the necessary tcp/ip. [if you still lock unbind this as well]. When you Restart and you should now be able to go in and remove RAS

Collapse -

NT Service Database Lock

by firesheep43 In reply to NT Service Database Lock

Unfortunately, when trying to unbind - it showed the DB lock and bluescreened.

Collapse -

NT Service Database Lock

by Mackem In reply to NT Service Database Lock

I have had similar problems to this and the answer was to uninstall the NIC card. this removes RAS and TCP/IP. Reboot, check to make sure the protocols have been removed, reinstall NIC and service pack 6.0a. Reinstall services & set tcp/ip to either dhcp or static.
You should be ok after this. When you are sure it is ok update ERD.
Best of luck
JV.

Collapse -

NT Service Database Lock

by firesheep43 In reply to NT Service Database Lock

Well, the NIC was not installed, though an integrated NIC is on the MB...... what finally worked was removing Workstation, then RAS, IP, etc- basically stripping about every service off the machine, putting SP6a on, then reinstalling each one at a time, reinstalling 6a after each and so on till it was done.

Collapse -

NT Service Database Lock

by firesheep43 In reply to NT Service Database Lock

This question was closed by the author

Back to Windows Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums