General discussion

Locked

NTOSKRNL.EXE after Slackware install

By nobby57 ·
Situation before install: IBM laptop running
W2K SP4 with all updates - 40GB HDD with
following partitions ---

C: FAT boot files only 255 MB
Linux Ext2 with nothing on it--holding place
FAT32 Music 6GB
E: NTFS W2K system files 4GB
F: NTFS apps & data 8GB
G: Ghost backup files, System State backups

Did Slackware Linux install on the reserved
linux partition (there is only one primary
partition, C: -- starting with the linux partition
everything else is logical) and after normal
install which worked fine found I could not
boot Windows. Get error after normal boot
menu screen saying that ntoskrnl.exe is
missing or corrupt. I did not install LILO,
choosing for now to boot Linux from a floppy
just so I could leave the W2K stuff entirely
alone. Have read advice saying to edit boot.ini
file to reflect new partitions -- if so, how is that
done? Through the Recovery Console? Given
the info above, what number partition would I
change to? Here are the linux partitions ---

hda5 /
hda6 82 (swap)
hda7 /usr
hda8 /home

These are all (except swap) logical linux
Reiser file system partitions which I thought
were invisible to Windows so I didn't think the
Windows view of things would be changed at
all. Anyway, I need advice on changing that
boot.ini file. I know the rest of the windows
installation is OK because at first I thought
something WAS corrupt and so ghosted back
the C: and E: partitions with no change.

Thanks!

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by nobby57 In reply to NTOSKRNL.EXE after Slack ...

I had wanted to avoid using LILO on the MBR because I had never used it with W2K before and I didn't know what would happen -- and the W2K partitions have stuff on them that I need to use, navigation stuff and so on that so far I only have Windows programs to use. So I thought the best setup would be to keep the NT boot loader and boot from floppy for now and maybe later install LILO to the Linux partition and add a line to the NT boot loader to send it there. But maybe this is the time to experiment a little and give LILO a try. So far I have edited the boot.ini file to read partition(7) and then (8), both with no result except the same ntoskrnl.exe error. I didn't know whether to count the extended partition as a seperate partition to be counted, or just the logical partitions inside the extended partition. But both methods seem to be wrong if I have counted right.

Collapse -

by mysuse In reply to NTOSKRNL.EXE after Slack ...

I would like to help you to restore your win2k back, it's a common error from windows 2000 because of changes in partition number of HD. You have to edit boot.ini files to tell whereis the Partition for Windows 2000. First of all You need to know which partition is belong to your windows. Run this command from linux

fdisk -l /dev/hda
( to list all partition in your hd)

Then look at the list, find which one belong to win2k which has HPFS/NTFS file system, the first one on the top of the list should get number 0,second is 1, the 3rd is 2 and so on. So which number is your HPFS/NTFS partition.

After you figure that out, edit your boot.ini by using recovery console, and edit this line

[operating systems]
multi(0)disk(0)rdisk(0)partition(X)\WINNT="Microsoft Windows 2000" /fastdetect

change partition(X) to your HPFS/NTF number you got from "fdisk -l /dev/hda" command

Note**
Before you doing this, try to backup your boot.ini first.

Then try to reboot your computer. If everything is still goes wrong please let me know.

Collapse -

by nobby57 In reply to

Poster rated this answer.

Collapse -

by nobby57 In reply to NTOSKRNL.EXE after Slack ...

OK, problem resolved. Here is what I did:

1. Looked at the partition table in Recovery
Console using the fixpart command. It looked
very strange -- so strange I thought the
partition table might really be corrupted -- but I
did note that it regarded the E: partition, which
is where the W2K system files reside, as
partition 3.

2. Booted into Linux (since I could find no way
to edit the boot.ini file in RC -- I'm sure there is
one, but I couldn't dope it out). Edited the
boot.ini file in vi to read "partition(3)".

3. Booted into Windows -- it worked.

What had had me confused was that the
ORIGINAL boot.ini file on C: had read
"partition(4)". No way, I thought, would the new
number be lower than (4) -- rather, with four
new Linux partitions, it must be the same or
larger. I tried to figure out how Windows was
counting those partitions! But every number I
came up with resulted in the same error.

In the end, the only explanation I could come
up with was that Windows COULD see the
original ext2 partition. (I had previously thought
Windows must be counting the extended
partition but couldn't see the Linux one, so I
thought the Slackware install would not do
anything to the partition table so far as
Windows was concerned, no matter how
many Linux partitions I added.) I thought that
by counting the extended, it got (4): C:,
Extended, , and E:. Now I realize it must
have counted: C:, ext2, , E:. But when I
installed Slackware and used the Reiserfs,
then Windows could see nothing where ext2
had been or thought that that part of the disk
was simply corrupted. So it counted: C:, , E:.

Anyway, mysuse, your answer comes closest
to what I did so you will get the points. I will
leave the question and answer up for a few
days so others can see it -- hope it may help
another dual booter!

Thanks, Reid

Collapse -

by nobby57 In reply to NTOSKRNL.EXE after Slack ...

This question was closed by the author

Back to Linux Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums