Office 2007 Slow Network Saves

By steventcullen ·
Hello Kind World,

I have recently installed Office 2007 on 2 Vista Machines on a Windows Server 2003 network. When I go to Save As any file in Word 2007, Excel 2007, Outlook 2007, no matter small or big, it sits there for anywhere from 20seconds to 2 minutes staring at me. Browsing the network drive is quick. When I go to copy files onto the network there is a massive delay also. All of my other machines (XP) work perfectly fine.

I think this is a big problem with Vista, Office, and Older OS's communicating together and I haven't found anything on the knowledge base or the web. The reason I say it is big is because I mimicked it on 2 Vista computers on my network.

This is really effecting the produtivity of our company. Any leads will help.

Thanks kind world,


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Office 2007 Slow Network Saves

by howardd In reply to Office 2007 Slow Network ...

Exactly the same problem here. Can click on save and excel 2007 takes 35 seconds to save even if I haven't made changes.

Same network as you.. 2k3 server R2 with XP Pro and Vista Business clients. Xp Machines save without problems or delays but the Vista machines all have the same slow save issue.

I have tried many possible fixes including the supposed hotfix, however the hotfix does not cover this issue. At least it did nothing for me.

1 possible fix is this one taken from another forum?

?I configed Windows Firewall with Advanced Security. Opened outbound rules allow all. Goto control Panel, swith to Classic View,click on Administrator tools,go into Local Security Policy, and there you will see firewall folder. Setup the profile your using with a new outbond rule. I had my fire wall off the whole time and still do, but this worked. I hope it works for you. Windows Vista has outbond rules in it's firewall unlike XP only having inbond. Silly me to think that when I shut off the fire wall that everything would be wide open. Aparently This has to be manualy set regardless. My transfer rate went from AVG 2.5MB to 72.3MB over Gigbit.?

Another possible fix from another forum:

?Slow Network Issues
Microsoft Windows Vista comes with a new network stack that can adjust or tune itself. On some machines rather than help file transfer speeds it actually slows it down. Many times this issue is caused by third party network drivers.
Auto tuning can also slow down network browsing of other machines on your network. If you are having local network slowness or file transfer problems try the command below to turn off autotuning.
You can turn on and off autotuning with a simple command line instruction.
Run the command at a command prompt (cmd.exe), you may need to run the cmd.exe as an administrator (right click "run as administrator"). Command Prompt by default is located under the Accessories menu folder. If you are logged in as administrator you can simple click "start" then "run" type in: cmd.exe and then run it.
To turn off AutoTuning
netsh interface tcp set global autotuninglevel=off
To turn on AutoTuning
netsh interface tcp set global autotuninglevel=off?

And the Hotfix:

Link to the Download:

If you have learned something new please share.. This is becoming a real pain in the you know what?

Collapse -

Office 2007 Slow Network Saves

by sales In reply to Office 2007 Slow Network ...

Same problems, turning the autotuning off does not really do anything. But try turning off your antivirus software. It made a big difference on mine.

Collapse -

Mapped Drives?

by kristina_johnson In reply to Office 2007 Slow Network ...

If you have any old drive mappings, try disconnecting them. I had an issue at my office there was a major delay opening the network drives from office 2007; disconnected an old drive mapping and it fixed the problem.

Related Discussions

Related Forums