Office WORD and "This document could not be registered."

By joelicketto ·
I am running WinXP Professional, SP2.
I began experiencing problems with MS Office 2002 products about 3 weeks ago. Our desktop GIS group could not help with the issue, so I asked to be upgraded to MS Office 2003. We unistalled MS Office XP and did a "clean" install of MS Office 2003. MS Office WORD is experiencing a new symptom that no one appears to be able to resolve. When I open a new document, I get a message box with the following - "This document could not be registered. It will not be possible to create links from other documsnts to this document." The only feature that I have noticed that is not functioning so far is "Drag and Drop" editing. Yes - this feature is selected from the Options\Editing control panel for MS Word.
Additionally, when I open a previously saved and closed document, I get the follwong message which appears related to the the new document message. The message is as follows - "This document could not be registered. It will not be possible to create links from other docuemnts to this document. (<path>\<filename>)"
When attempting to create a hyperlink to another WORD or PDF document and open the H-Linked doc, eveything appears to function OK.
If anyone has any good clues as to what may have gone wrong in my system to cause this, I would appreciate some assistance. Thanks

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Office WORD and "This document could not be registered."

by nyanlinmm In reply to Office WORD and "This doc ...

Please check if the service "DCOM Server Process Launcher" is set to Automatic and running.

MS word warns if the process cannot be registered on computer if this service is not running.

To check, click Start->Run->type Services.msc->click ok.

Collapse -

Office WORD and "This document could not be registered."

by joelicketto In reply to Office WORD and "This doc ...

Thank you very much. Your tip worked like a charm after a system reboot.

Collapse -

OK problem is solved ThQ

by jaya28inside In reply to Office WORD and "This doc ...

Hope it;s ok now
Even when i was trying to start the DCOM service showing an error, dont know what the words are...

But, now
there's no MS word says, "couldnt be registered"anymore... ThQ :)

Collapse -

Here is the fix...

by rkarthik25 In reply to Office WORD and "This doc ...

Apparently the problem is due to the ?DCOM Server Process Launcher? service not starting. Set the start type to "automatic".
You can acess the services by hitting "services.msc" in the run window and choosing the above mentioned service.Right click and change the start up option.This should solve the issue

Collapse -

Word repair

by ratiug6 In reply to Office WORD and "This doc ...

I had the same issue. The following file fixed it. Just unzip and run the regfile.

Collapse -

A Different Fix (Word 2k on W2k)

by service In reply to Office WORD and "This doc ...

I had the same error with Microsoft Word from Office 2000 running on Windows 2000 Professional. In my case the problem was that the 'Remote Procedure Call (RPC)' service, which *was* set to Automatic start, had been shut down by my BlackICE firewall, in response to a malformed RPC packet from a Internet-based hacker. I manually restarted the RPC service. Word needed to be stopped and restarted after that. Before the fix, I could not copy (^C) text from another application and paste it (^V) into an old text file that Word had opened with the message "This document could not be registered...".

Collapse -

Problem solved - Thanks

by joelicketto In reply to A Different Fix (Word 2k ...

Thanks for all of the helpful hints. The problem has been fixed by following good advise.

Collapse -

No solution here works in my case

by sfyang In reply to Office WORD and "This doc ...

I have tried all the solutions suggested in this post. But none of them works in my case. I am still getting the same error "This document could not be registered..."

I have also searches a solution generally on the Internet. No luck there.

Any ideas?

Collapse -

Same thing here, but I fixed it ...

by info In reply to No solution here works in ...

I had this same problem too on a Windows 2003 server for one of my clients. I found a bunch of different "fixes" on the web, including those posted here.

None of them worked. I already had all the proper services started, all the proper regkeys, I uninstalled and reinstalled Office (including removing all files and regkeys by hand), uninstalled Windows updates and fixes, reboot dozens of times ... and still nothing worked.

Finally, I found the problem. The DCOM Access List for the Word executable somehow (during a Windows service update) became corrupted.

The solution that worked for me:

1. Choose Start > Run, enter Dcomcnfg and hit OK.

2. Find the entry for Word under Computers > My Computer > DCOM Config.

This entry might say "Microsoft Word Document", "Word Document", "Document", or might just be the GUID for Winword.exe - in my case, it was the GUID {00020906-0000-0000-C000-000000000046}

3. Right-click on this entry and choose Properties.

4. Click on the Security tab

5. Under Access Permissions, if you currently have Customized access permissions, and you still need them, click on the "Edit" button, write down all the custom ones you have set. So you can reset them after the next step.

6. Now under Access Permissions, click "Use Default" and then the Apply Button. This will clear all the access permissions.

7. Now click "Customize" and the Edit button. Re-enter all the customized entries you wrote down in step #5 above.

That's what fixed this problem for me.

Al Simon

Collapse -


by skhalis In reply to Same thing here, but I fi ...

Thanks for the insight. Worked perfectly.

Related Discussions

Related Forums