Old Hard Drive now slave no drive letter

By dhiltner2 ·
I have had to replace a computer that had a defective motherboard with a new computer. I have taken the only HDD out of the old PC (windows XP) and I made it the slave HDD in the new comptuer (also XP)to copy some data from old to new. After booting up, the new computer recognizes the old HDD as slave in CMOS and displays it in Disk Management but whithout a drive letter. I have tried rescanning and all other functions are greyed out except "delete partition". Old HDD is a 40 gig Maxtor Fireball 3 IDE. I have tried slaving this drive in several PC's to make sure it wasn't the new comptuer and get the same result. Is this a new security thing with windows XP? Does the Maxtor drive need specific drivers installed? I remember the old days when you could slave a drive and copy what you wanted. How can I get the new computer to give the slave drive a drive letter whithout having to delete partition and format?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

By Chance

by Langlier In reply to Old Hard Drive now slave ...

does the old drive have Norton Goback or something similar installed on it?

Collapse -

Norton GoBack

by dhiltner2 In reply to By Chance

Yes, I beleive the old drive does have that installed.

Collapse -

Boot from the old drive

by Langlier In reply to Norton GoBack

and remove goback. Everything will work fine after that. GoBack - worst POS norton ever made.

Collapse -

Boot from the old drive

by dhiltner2 In reply to Boot from the old drive

LOL, I will try that. Thanks

Collapse -

Import the drive or Add Signature

by sgt_shultz In reply to Old Hard Drive now slave ...

Yes, maybe you need drive overlay software. But I think you haven't gotten that far yet. Maybe you just need to let XP know about the drive. (its not a bug, its a feature)
I don't have xp in front of me but if you go to disk management (Control Panel/Administrator Tools) and locate the drive in quesiton you can right click on it and probably get 'import' or 'add signature'
will not hurt the data on the disk
then if you can't read or boot it you might have the drive overlay problem...

Collapse -

All other functions greyed out

by dhiltner2 In reply to Import the drive or Add S ...

Other than the ability to delete the partition. All other options are greyed out in disk management

Collapse -

Same thing happening to me

by aristideau In reply to All other functions greye ...

I am having exactly the same problem, I have 3 drives in my m/c and I had to reinstall windows over the weekend. Now one my drives is only recognizedby Disk management but not by the OS. Like you all options are greyed out excpept Delete Partition.

Just wondering if you have resolved it.

Collapse -

Ditto! I have the exact same problem

by kopie54 In reply to Same thing happening to m ...

I recently installed Windows XP Pro MCE on a spare SCSI drive I had. After installation was completed I connected the drive that was previously the Drive in my XP Professional setup. The drive has all my hardware drivers on it etc.

The SCSI host adapter picks the drive up no problems and it is present in Device Manager and in Administrative Tools/Computer Management. It has no drive letter assigned to it however and when I highlight the drive in Computer Management and call up the right click menu all the options are greyed out except "Delete Partition and Help".

I have un-installed the drive in Device Manager I have used the Rescan Drive function in Computer Management and also in Diskpart from the Command Prompt also tried the assign command in Diskpart, and a few other things.

Can anyone shed any light on what is happening here? It seems to me that the OS is not recognising the drive it is formatted Fat32 has no errors on it checked it using SeaTools and Norton Disk Doctor.

It is picked up without any problems in my XP Pro set up in fact with my XP Pro set up if I add another SCSI drive it recognises it as new hardware and suggests a re-boot to properly install the drive. The Media Centre Edition never did this.

Again what is happening here?

Collapse -

Not very clear!

by ComputerCookie In reply to Ditto! I have the exact s ...

How did you install the OS on the hard drive if it wasn't connected to the computer.

Unless you used another computer that had the same motherboard, your pushing you luck in resolving driver conflicts.

Did you configure the BIOS for the SCSI?
Why are you using FAT32?

Collapse -

Ok I'll explain read carefully please.........

by kopie54 In reply to Not very clear!

I run a few SCSI HDDs. I wanted to install MCE on a spare drive that I wasn't using which at this point was sat on my desk and not connected.

I disconnected the other drives and connected the spare drive that I had. I now have 1 drive connected the others have temporarily been disconnected.

I installed MCE edition on the spare drive that is now connected and the other drives are still temporarily disconnected. MCE installs without any problems using an NTFS Partition and works perfectly.

I close down the MCE OS and connect the SCSI HDD that was my Drive previously it is partitioned FAT32 and has all the hardware drivers I need and software I use, all Programs are in an installable form. This drive was previously in a Windows ME PC that I have.

I now have the MCE OS on the spare drive I connected and now the Drive connected (the 2nd SCSI HDD). When I boot the MCE OS it boots up fine, no problems but the 2nd HDD is not shown in My Computer it is present in Disk Management (without a drive letter) and is also shown in Device Manager.

I did have Norton Go Back installed on the XP Professional Drive the original HDD that I disconnected to install MCE on the spare SCSI Drive I had which is now connected with the Drive.

Below is answers to your reply in the order that you asked your questions.

The drive was connected when I installed MCE.

I didn't use another PC with the same hardware to resolve driver conflicts. I don't have any driver conflicts.

The BIOS is configured perfectly for my SCSI setup.

The Drive (2nd SCSI HDD) was Partitioned using FAT32 in a Windows ME PC.

The newly installed MCE OS I used NTFS Partition.


I hope this clears up any confusion and you can now shed some light as to why MCE OS is not allocating a drive letter to the 2nd SCSI drive I connected. Is it as previously mentioned in this topic to do with Norton Go Back?

Related Discussions

Related Forums