General discussion

  • Creator
    Topic
  • #2177003

    one Lan connected to another via T1, can’t get them to see each other.

    Locked

    by jgard ·

    Ok, here we go. I have a T1 line that is supposed to connect my LAN at my datacenter to my LAN here at the office. I have at the data center IP addreaa range of 10.2.0.1-255 here at the office it is a 10.0.0.1-255 network.

    on each end is a cisco 1721 set.

    router datacenter is configured as:
    serial0:
    ip address 10.1.0.1 255.255.255.0

    router eigrp 1
    network 10.0.0.0
    auto-summary
    !
    fastethernet0
    ip address 10.2.0.1 255.255.255.0
    speed auto
    half-duplex
    no cdp enab

    OK router main office is configured as:
    serial0
    ip address 10.1.0.2 255.255.255.0

    router eigrp 1
    network 10.0.0.0
    auto-summary

    fastethernet0
    ip address 10.0.0.2 255.255.255.0
    speed auto

    this is what I have so far, but I am unable to see the computers from one end to another.

    Thanks,
    jeff,

    if you have more questions or want to contact me by email jgard@mcstrategies.com or call me at 1 800 999 6274 ask for jeff.

    I’ll give unlimited points to whoever helps me get this thing going where I can send data from a machine here to one at the datacenter.

    unfortunately I can only give 350, and if I ever get more i’ll give them to you too.

All Comments

  • Author
    Replies
    • #3351361

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by cg it ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      when you ping each interface and you’ve got to try to ping them, all what happens?

      Why don’t you run a running config for us and paste it [change passwords and IP values but be accurate when you change IP values e.g.

      The 1721 is an Access Router, so do you have any access lists? If you have access lists defined, you might want to disable them and try a connection.

      • #3350773

        Reply To: one Lan connected to another via T1, can’t get them to see each other.

        by cg it ·

        In reply to Reply To: one Lan connected to another via T1, can’t get them to see each other.

        This doesn’t really answer the question because I’ve just briefly looks at the running config but one thing that stood out is the gateway of last resort. Needs to be 0.0.0.0 [or as you did, specify a router].I didn’t see any access lists so thats not the problem.

        appears to be a route problem and I’d say subnetting. it appears that both segments are using the 24 bit host addressing [10.X.X/24] might want to recheck your subnet addressing.

      • #3350772

        Reply To: one Lan connected to another via T1, can’t get them to see each other.

        by cg it ·

        In reply to Reply To: one Lan connected to another via T1, can’t get them to see each other.

        change one of the subnets to 10.X.X/16 instead of /24

    • #3351214

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by den_blc ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      I can’t see what type of encapsulation do you use on serial interfaces. I think you use Cisco T1/E1 Multiflex Voice/WAN Interface Cards.
      In this case try to use this config.
      Router datacenter:

      controller T1 0
      framing esf
      clock source internal
      linecode b8zs
      channel-group 0 timeslots 1-24
      !
      interface Serial 0:0
      ip address 10.1.0.1 255.255.255.0
      encapsulation ppp
      !
      interface FastEthernet0/0
      ip address 10.2.0.1 255.255.255.0
      !
      no router eigrp 1
      !
      ip route 10.0.0.0 255.255.255.0 serial 0:0

      Router main office:

      controller T1 0
      framing esf
      clock source internal
      linecode b8zs
      channel-group 0 timeslots 1-24
      !
      interface Serial 0:0
      ip address 10.1.0.2 255.255.255.0
      encapsulation ppp
      !
      interface FastEthernet0/0
      ip address 10.0.0.2 255.255.255.0
      !
      no router eigrp 1
      !
      ip route 10.2.0.0 255.255.255.0 serial 0:0

      Or you can find something useful here:
      http://cisco.com/en/US/products/hw/routers/ps221/prod_configuration_guide09186a00800a4063.html#144665

    • #3350034

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by jgard ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      hey guys here is the running config file:

      I was told by another to actuallyget rid of eigrp and use a static route. with EIGRP on I was able to see each router on each side.

      with the static route I can still see each router and can ping, but still cannot actually computer to computer from each network.

      Current configuration : 754 bytes
      !
      version 12.3
      service timestamps debug datetime msec
      service timestamps log datetime msec
      no service password-encryption
      !
      hostname datacenter
      !
      boot-start-marker
      boot-end-marker
      !
      enable secret 5
      enable password
      !
      mmi polling-interval 60
      no mmi auto-configure
      no mmi pvc
      mmi snmp-timeout 180
      no aaa new-model
      ip subnet-zero
      ip cef
      !
      !
      !
      no ftp-server write-enable
      !
      !
      !
      !
      interface FastEthernet0
      ip address 10.2.0.1 255.255.255.0
      speed 10
      half-duplex
      no cdp enable
      !
      interface Serial0
      ip address 10.1.0.1 255.255.255.0
      encapsulation ppp
      !
      ip classless
      ip route 10.2.0.0 255.255.255.0 10.1.0.2 permanent
      no ip http server
      !
      !
      line con 0
      exec-timeout 0 0
      line aux 0
      line vty 0 4
      password
      login
      !
      !
      end

      Current configuration : 613 bytes
      !
      version 12.3
      service timestamps debug datetime msec
      service timestamps log datetime msec
      password:
      !
      hostname main office
      !
      boot-start-marker
      boot-end-marker
      !
      !
      mmi polling-interval 60
      no mmi auto-configure
      no mmi pvc
      mmi snmp-timeout 180
      no aaa new-model
      ip subnet-zero
      ip cef
      !
      !
      !
      no ftp-server write-enable
      !
      !
      !
      !
      interface FastEthernet0
      ip address 10.0.0.2 255.255.255.0
      speed 10
      !
      interface Serial0
      ip address 10.1.0.2 255.255.255.0
      encapsulation ppp
      !
      ip classless
      ip route 10.0.0.0 255.255.255.0 10.1.0.1 permanent
      no ip http server
      !
      !
      line con 0
      line aux 0
      line vty 0 4
      !
      !
      end

      • #3350027

        Reply To: one Lan connected to another via T1, can’t get them to see each other.

        by jgard ·

        In reply to Reply To: one Lan connected to another via T1, can’t get them to see each other.

        Also when I do a show ip route this is what I get

        Gateway of last resort is not set

        10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
        S 10.2.0.0/24 [1/0] via 10.1.0.2
        C 10.2.0.0/16 is directly connected, FastEthernet0
        C 10.1.0.2/32 is directly connected, Serial0
        C 10.1.0.0/30 is directly connected, Serial0

    • #3350020

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by den_blc ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      Seems like computers don’t have routes to another network… What default router have computers in datacenter network? If not 10.2.0.1, then on each computer you need to add route:
      route add -p 10.0.0.0 mask 255.255.255.0 10.2.0.1
      And on each computer in main office:
      route add -p 10.2.0.0 mask 255.255.255.0 10.0.0.1
      (This commands for MS Windows)

    • #3349894

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by benjamin.arnold ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      I think I got it? if this is right then I think your going to laugh about it.

      In the router with the serial address of 10.1.0.1 it has a static route of

      10.2.0.0/24 goto 10.1.0.2

      ip classless
      ip route 10.2.0.0 255.255.255.0 10.1.0.2 permanent
      no ip http server

      and then on the router with the serial address of 10.1.0.2 you have a static that says?

      10.0.0.0/24 go to 10.1.0.1

      ip classless
      ip route 10.0.0.0 255.255.255.0 10.1.0.1 permanent
      no ip http server

      You have them backwards I think. The router 10.1.0.1 also has the FE interface 10.2.0.1 on it? but your telling it that in order to get to that network you have to go to 10.1.0.2, which is the other router. Since there is no default route it drops the packets there.

      Then the router 10.1.0.2 with FE 10.0.0.2 has a static route that sends 10.0.0.0 to 10.1.0.1. That router has no default gateway and drops those packets.

      You just have to change the static routes around. You don?t even have to run EIGRP. Just make sure you can ping across from 1 router to the other first.

      I e-mailed you my response. Good Luck!!

    • #3350906

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by sgt_shultz ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      i wish for more info about exactly what server and application exactly needs to talk to each other. but having said that…just 2 cents:
      tell mgmt you need replacement routers as cheap insurance for these single points of failure. say you need 2. call up cisco sales and tell them what you want to do. pump them for information. buy the spares pretend you are configuring them in advance as spares. this will get you a whole test lab thing going which is what you need. visit the cisco website and learn how to remotely configure and secure them, back them up and restore them. learn what breaks communication. figure out how you gonna reload your backup from afar when you accidently break tcpip. ask cisco to walk you thru setting up static routes. but tell them what you are trying to get done. maybe you need some port forwarding too. or something. do you require to browse the remote network. ask them for pointers on securing the routers

    • #3331101

      Reply To: one Lan connected to another via T1, can’t get them to see each other.

      by jgard ·

      In reply to one Lan connected to another via T1, can’t get them to see each other.

      Well here it is with all that information that is on ee and your added suggestions, I am still only able to ping from router to router, but when I do a tracetr from each machine the packets are actually trrying to go out the public ports. Meaning I have on the main office a router that shooots out to the internet and a router that is supposed to go to the other LAN. On the datacnter side I have a line that goes to a bridge for our outside IP’s, and a router for the main office location. For some reason everytime I try to ping all routes try to go out the public routers. Do you know what I have to do to get it to point to the private T1 router, and still have the outside addresses be public?

Viewing 6 reply threads