Opening Excel Attachment from Outlook 2003

By rbowers ·
I have just started having a problem where I cannot access Excel files sent to me. I run Outlook 2003, and when I try to open or save the attachment I get the following message :

Can't create file: Filename.xls, Right-click the folder you want to create the file in, and then click the shortcut menu to check your permissions for the folder

I have tried 'detect and repair' from Outlook help, and have deleted the contents of the temporary internet files folder.

Any ideas what else it could be?


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Is it possibly an association issue?

by lmayeda In reply to Opening Excel Attachment ...

Did you say that you can't even SAVE the attached file? If you can save it, then Open Excel first and then open the saved file. If you cannot save it as .xls, try saving it as a .txt file, then try opening it from Excel. How about trying to re-install Office Pro?

Collapse -

Default Outlook attachment folder

by CharlieSpencer In reply to Opening Excel Attachment ...

By default, when you open an attachment in Outlook, the file is created in C Documents and Settings \ yourusername \ My Documents. This folder is used even if you have assigned the desktop My Documents folder to another location, such as a network drive. I suspect that's what the error message means: Outlook can't create the attachment as a file in the My Documents folder. Check the permissions on that folder.

Until you can get the problem fixed, remember you can always right-click the attachment, select Save, save the attachment as a file in a folder, then go to that folder and open the file.

Collapse -

Problem can be > 99 files with same name in temp folder

by conor In reply to Default Outlook attachmen ...

Outlook 2000, XP, and 2003 Can't Open PDF or TIF Attachments
You may receive the following error message when opening attachments in Outlook (such as PDF faxes):

"Can't open this item. Can't create file: send2fax1.pdf. Right-click the folder you want to create the file in, and then click Properties on the shortcut menu to check your permissions to that folder"

Microsoft Outlook uses a temporary folder to save and open the attachments. By default that folder is hidden and the only way to locate it is to look in the Registry:

1. Open REGEDIT.EXE and go to Edit -> Find... In the Find dialog box type "OutlookSecureTempFolder" without the quotes and locate that registry key.
2. That key will contain the actual folder location, and will look like:
C:\Documents and Settings\%USER_NAME%\Local Settings\Temporary Internet Files\OLK#\ (where # is a random letter or number)
3. Copy the location of that folder.
4. Click on Start -> Run... and paste the folder location from step #4 then click OK.
5. Windows Explorer will open that folder. Please, delete all files present.
6. Restart Microsoft Outlook and you should be able to open your attachments.

(I had this problem some time ago and found the above solution somewhere - apologies for plagiarizing the original writer but I cannot remember from where. While searching today I remembered I had emailed it to a colleague - hope it helps).

Collapse -

it works

by jhbobo In reply to Problem can be > 99 files ...

i have exp the same problem with one of my user and i have tried the above method and it works. thanks for the tip

Collapse -

Thanks, it worked for me too... & it works for any type of file extentions.

by geek-goddess In reply to it works

Anyway, to prevent these temp files from building up in those temp directories, so that a manual deletion is not required?

Thanks and keep up the great job!
Glad to be a member!


Collapse -

thanks. more helpful

by Gayan Senarathne In reply to Problem can be > 99 files ...

Anyway it is more helpful for me thanks again.

Collapse -

it`s great info from outlook

by srinut31 In reply to Problem can be > 99 files ...

tahnk for your info .
i add u man .

Collapse -

Neat Fix

by rkhan In reply to Problem can be > 99 files ...

Excellent, thanks for the quick fix. Thanx for sharing.

Collapse -

Worked perfect

by peggy.salberg In reply to Problem can be > 99 files ...

Thanks so much for this solution

Collapse -

Great fix!

by aaron In reply to Problem can be > 99 files ...

This fixed the problem one of my users was having with outlook 2003 opening an excel 2003 file. Thank you!

Related Discussions

Related Forums