General discussion

Locked

opening foxpro database

By fsl007_pk ·
hi
i am opening foxpro 2.5 database in my ASP application. its working fine when i am opening it with the following line on the same machine:
cn.Open "Provider=MSDASQL.1;Persist Security Info=False;Extended Properties=Driver={Microsoft FoxPro VFPDriver (*.dbf)};UID=;SourceDB=C:\Prod\pso\crm\db\;SourceType=DBF;Exclusive=No;BackgroundFetch=Yes;Collate=Machine;Null=Yes;Deleted=Yes;"

but not working while database is on the other machine and using this line:
cn.Open "Provider=MSDASQL.1;Persist Security Info=False;Extended Properties=Driver={Microsoft FoxPro VFP Driver (*.dbf)};UID=;SourceDB=\\reporter\db;SourceType=DBF;Exclusive=No;BackgroundFetch=Yes;Collate=Machine;Null=Yes;Deleted=Yes;"

please help

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

opening foxpro database

by only_jitu In reply to opening foxpro database

Check the Database Driver and Network settings. Problem lies in between these two.It happened with me earlier.I resolved this by re-installing database driver on the other machine.

Collapse -

opening foxpro database

by fsl007_pk In reply to opening foxpro database

there is no problem in network settings and driver couz i have opened the same database through VB application with the same coding.but here the problem is when i am using it with ASP application.

Collapse -

opening foxpro database

by C1980 In reply to opening foxpro database

So, what is happening? Error? Database not found?

Collapse -

opening foxpro database

by fsl007_pk In reply to opening foxpro database

The question was auto-closed by TechRepublic

Collapse -

opening foxpro database

by ananthap In reply to opening foxpro database

Possibility 1.
As you typed it in, the right most character of SourceDB doesn't have a backslash in case 2 but does have in case 1.
CASE2--->\\reporter\db;
CASE1--->C:\Prod\pso\crm\db\;

Possibility 2.
\\ for computer names is a netBEUI or netBIOS style. It doesn't work well on WANs. If its on a WAN (or non-LAN), then you could try:
\\xxx.xxx.xxx.xxx instead od \\reporter

Hope it helps.
End of mail.

Collapse -

opening foxpro database

by fsl007_pk In reply to opening foxpro database

The question was auto-closed by TechRepublic

Collapse -

opening foxpro database

by fsl007_pk In reply to opening foxpro database

This question was auto closed due to inactivity

Back to Web Development Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums