Opening Mapped drive on 1 computer is slow

By bklein ·
We have many computers in a Domain and all open all mapped drives quickly. We have 1 computer that opens all mapped drives quickly except for 1 mapped drive (which is on the same server as the other ones.) In researching I opened a command prompt and did a netstat - and found a TCP session attempted to start to a non-existant computer in the domain. I suspect that after about 30 seconds or more, it times out and then the folder opens on the server. I'm trying to find out where the reference to that non-existant computer name is so I can remove it and hopefully solve the problem. I've searched for that computer name in the registry and it doesn't show up. Any ideas where else to look?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

AD account

by beanxyz In reply to Opening Mapped drive on 1 ...

Have you tried to check the settings in AD account. For example, under profile tab, you can setup the path.


Collapse -

Not related to AD

by bklein In reply to AD account

It's not related to the AD - if I map the drive to another letter it works fine; if I map it to the same (old) letter it hangs. I need to find where this information is kept to delete it and it seems not to be in the registy or I don't know where in the registry.

Collapse -

Delete the drive

by beanxyz In reply to Not related to AD

Have you tried command line like:
net user G: /delete

and force disconnect?

Collapse -

Disconnect Drive and remapp it and same problem

by bklein In reply to Delete the drive

I disconnect the drive; If I remapp it to another letter all is well; if I remapp it to the same drive letter the problem reappears.
Searched through the registry and can't find where the mapping is. Anyone know?

Collapse -

Map Drive in registry

by ameack In reply to Disconnect Drive and rema ...

Per user Drive mapping is stored under


and then a sub folder for the actual Drive, Say I have a P drive mapped to \\Server\Photos I will have the following Reg Keys:-

"ProviderName"="Microsoft Windows Network"

If you go to the command line, and type net use, you'll see all of the mappings in use, as well as some of the shares. That way, if you want to remove mappings, you can do net use Z: /delete
hope this helps

Collapse -


by bklein In reply to Map Drive in registry

Thanks, will look into that.
Problem got solved by changing Windows Explorer from Show Common Tasks in Folder to Windows Classic Folders under Tools->Folder Options. When it shows the common tasks it displays a Play Video as a common task for that mapped drive; when that is closed it just opens the mapped drive immediately. When I switch back to Show Common Tasks problem reappears.

Related Discussions

Related Forums