OpenSSH service won't start on Vista

By mindreleams ·

I am trying to install OpenSSH on Windows Vista. I log in as member of Adminstrator and install the package. Vista UAC does not give me Consent prompt but it give me a dialog saying unknown application is trying to get install on the system, probably because the installer is not signed.
Anyways after successful install when I reboot my pc, the OpenSSHd service simply do not start. If I try to start it manually, sometimes the service starts for a few seconds and then stops. Other times I get a dialog saying that service caused a problem. I am not sure why it is happening.
I thought since I am member of adminstrator and starting the installer at elevated level any sub process started by it would also run with elevated privileges.

When I try to retrieve the priveleges using SC.exe (from command prompt) it shows that service has "None" priveleges.
Also I am unable to set the priveleges for the serive using SC.exe as I get access denied error. Vista didn't allow me to change service SID type also. I do not want to set the service to run in compatibility mode (unless ofcourse it can be set to run in compatibility mode programmitically)

I have also tried to embedding a manifest file with requestPriveleges set to "requireAdminstrator", still the service won't start. I have tried marked the installer as well the actual service executable (cygrunsrv.exe) to run using requireAdminstrator, asInvoker, highestAvailable and various combination of these to get it run, but the service is simply not getting started.

The service only starts when I run it in XP compatibility mode, but I have to make the compatibility mode settings for "All Users". If I simply set the service to run in "XP compatibility mode" and check the "run as administrator" checkbox on the Compatibility tab, the service still doesn't starts!!

I have read that only local adminstrator/member of administrator and few more groups can set the priveleges for a service, but Vista is not allowing me to set the priveleges inspite I being a member of adminstrative group. I do understand that when a member of admin group logs on they are treated as standard user till they try to execute something that requires administrative action.

Please can someone throw some light on where I am messing the things? What settings do I need to make to run the service successfully so that it is available for other users also?

I am using a fresh Vista installation, with only one user created initially who is a member of administrator group. I have not tweaked any other security setting through group policies etc.

Thanks in advance.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Related Discussions

Related Forums