General discussion

  • Creator
    Topic
  • #2299409

    Opera works but IE doesn’t

    Locked

    by ramgarden ·

    We just installed Windows 2000 Server on our new Dell PE2650 along with AD (making it the root of a brand new forest on its own new domain), IIS, and Exchange 2000. We set up DNS by deleting the root “.” forward lookup zone and enable fowarders to the 2 real DNS servers. By REAL I mean actual root DNS servers. We pointed the TCP/IP settings of our server’s NIC to itself for DNS (which fowards to the other DNS servers just fine) and setup IE to use our proxy server (totally separate, standalone,proxy server). It should be noted we are a department of our university’s campus so the 2 root DNS, and the proxy server belong to them. This is the crazy part: DNS resolves the IP of the friendly names you type in IE, but the page never loads. To troubleshoot, we installed Opera 7 and BAM! web page heaven! We had the university guys watch the traffic to and from our server using Opera, then IE. Come to find out IE was TOTALLY BYPASSING THE PROXY SERVER and trying to connect straight to the webserver you wanted. My question (finally) is this: Why would IE not use the proxy server set in it? (We have tried all the different ways of the advanced options: Do not use proxy for these addresses, Bypass proxy for local, etc.)

All Comments

  • Author
    Replies
    • #3392429

      Opera works but IE doesn’t

      by ann777 ·

      In reply to Opera works but IE doesn’t

      Have you enabled the option to “Use the same proxy server to all protocols”?

      • #3392382

        Opera works but IE doesn’t

        by ramgarden ·

        In reply to Opera works but IE doesn’t

        Already tried it. Even though we are only worried about HTTP and read-only FTP through proxy’s firewall…

    • #3392386

      Opera works but IE doesn’t

      by joseph moore ·

      In reply to Opera works but IE doesn’t

      After you set the proxy settings in IE, open Regedit, and go to: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings

      Your proxy settings should all be in there.
      ProxyEnable should be 1
      ProxyServer should be the IP address and port of your proxy server.
      ProxyOverride would have any domains you don’t want IE to forward to the proxy server.

      Perhaps the Registry settings just didn’t take when you set them before! Personally, I have never seen this, but I guess itcould happen. Anyway, try and set them, and then see if they are there.
      If the Registry says to use the proxy, then IE “should” use it.

      hope this helps

      • #3392383

        Opera works but IE doesn’t

        by ramgarden ·

        In reply to Opera works but IE doesn’t

        Already tried that too. Found this elsewhere on techrepublic and it STILL goes around the proxy! I even highlighted My Computer in regedit and used FIND for all the different keys and set them all appropriately.

    • #3354503

      Opera works but IE doesn’t

      by spanky ·

      In reply to Opera works but IE doesn’t

      What is the Proxy? Does it require a standalone authentication? Are you specifying the FQDN of an internal (to your dept. or the univ.) server or an internet server?

      • #3354436

        Opera works but IE doesn’t

        by ramgarden ·

        In reply to Opera works but IE doesn’t

        Well, we figured out the problem, the week after posting this question. Dell gives you special software with their servers that allow you to do a little remote administration via a web browser. Apparently, when this is installed it makes IE ignore the proxy settings. We uninstalled the Dell software and didn’t change the proxy settings and it worked. So to test, we left the proxy settings alone and reinstalled the Dell software. IE didn’t even try to use the proxy. We decided we didn’t need to remotely admin the server so we just left it uninstalled. Crazy stuff…

    • #3354435

      Opera works but IE doesn’t

      by ramgarden ·

      In reply to Opera works but IE doesn’t

      This question was closed by the author

Viewing 3 reply threads