General discussion

Locked

Outlook 2007 opens email attachments slowly...

By ClayGoss ·
I have a user (CEO) that has Office 2007. When he opens Excel, Word and PDF attachments, they open very slowly. I found where turning off DDE in Folder Options > File Types > "Extension" > Edit > uncheck DDE and add "%1" to "Application used to perform action:" field would fix this - AND IT DOES! Just one problem - within a week, days, sometimes hours, he is fussing again and when I look at the settings, they are back to using DDE.

Anyone know how to make these changes stick?

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

i'm curious

by PurpleSkys In reply to Outlook 2007 opens email ...

how much ram does his machine have?

Collapse -

Is he aware of the attachment preview capability?

by CharlieSpencer In reply to Outlook 2007 opens email ...

In 07, if he single-clicks the attachment instead of double-clicking in, the attachment can be viewed in the message window. It's handy if he only needs to read the attachment but not edit it (esp. .PDFs). Is that any faster or slower?

Collapse -

I did a little searching on the web....this is what I found...

by Darryl~ Moderator In reply to Outlook 2007 opens email ...

It seems this is a very common problem for people who have FireFox (or another Browser that doesn't support DDE) set as their default browser...

Edited to add ->

the common problem is that the setting keeps coming back....not the slow opening files, but it should still be related to the same thing....the others were mostly getting an error when clicking on links in FireFox...a few were having problems with MS Office programs.

<- End edit

This is the only fix I found anywhere that people seemed to claim that actually worked for them....give it a try, but I'd back up the registry keys first...

_____________________________________________

You will need to manually edit the registry in Windows Vista or in cases where the File Types listing is missing certain entries such as "URL:HyperText Transfer Protocol" (HTTP) and "URL:HyperText Transfer Protocol with Privacy" (HTTPS).

Caution: Editing the registry incorrectly can damage your system. Do not attempt these steps if you are inexperienced or uncomfortable using the Registry Editor.

1.Go to "Start -> Run" (or press the windows key+R) then type regedit and click OK
2.Use the directory tree hierarchy to navigate to "HKEY_CLASSES_ROOT\HTTP\shell\open\ddeexec"
3.Delete the "ddeexec" registry key
4.Repeat for "HKEY_CLASSES_ROOT\HTTPS\shell\open\ddeexec" (and any other protocols you want to fix)
5.Repeat for "HKEY_CLASSES_ROOT\FirefoxURL\shell\open\ddeexec"
6.Repeat for "HKEY_CLASSES_ROOT\FirefoxHTML\shell\open\ddeexec"

Back to Software Forum
3 total posts (Page 1 of 1)  

Related Forums