General discussion


Outlook Web access SSL

By Gr@ndcri ·
Any idea why I can't access Outllook web access after I setup SSL.
I got the error <<This page cannot be displayed>> If I don't use the
<<HTTPS>> I get the <<The page must be viewed over a secure channel>>.

If I unchecked Require Secure Channel its starts working with regular HTTP.

Thank for your help.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

by Gr@ndcri In reply to Outlook Web access SSL

Point value changed by question poster.

Collapse -

by p.j.hutchison In reply to Outlook Web access SSL

Where did you get the certificate from? Your own Certificate Authority server or a thirty party CA eg GlobalSign?
SSL certificates on IIS must have a private/public key pair to work correctly and have a valid certificate path to the CA (ie the CA certificates are installed and upto date).

Collapse -

Im with PJ

by CG IT In reply to

If it's an internal certificate being used, you should get a warning of unsigned certs in the browser. Until you install the cert, the browser won't display the SSL page as PH said. The keys have to work.

Collapse -

by curlergirl In reply to Outlook Web access SSL

Need more info. Are you accessing from inside or outside your network? Are you seeing a logon box first or not? Do you get any kind of message to accept a security certificate? Which web site directories have you set to require SSL? Have you made sure that the SSL certificate is correctly installed on your network?

Hope this helps!

Collapse -


by TheGooch1 In reply to

Did you ever resolve this issue?

Collapse -

Worked for me

by themickster In reply to Outlook Web access SSL

Had exactly the same problem. Turned out to be a problem with my home made certificate. This is what eventually fixed my problem and enabled https:

It was alot less complicated than setting up my own CA.

Related Discussions

Related Forums