General discussion

Locked

Password Protecting FrontPage Webs

By mike_jose ·
I setup a IIS 5.0 web server running FrontPage Server Extensions. How can I set it up so that, when a user has FrontPage open and tries to open my root web and subwebs using an http protocol, i.e. http://mycompany.com/subfolder it will prompt for them for their domain user name & password? I want it to work without causing any problems when trying to access http://mycompany.com/subfolder using their IE browser. I have my root web/subwebs stored in c:\inetpub\wwwroot folder.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Password Protecting FrontPage Webs

by banyanman In reply to Password Protecting Front ...

Open up you Internet Services Manager. Right Click on your Web Site, if you haven't renamed it, it will be called Default Web Site and click on Properties. Once the properties window opens up, click on the Directory Security Tab. Then in the areafor Anonymous access and authentication click on edit and uncheck the checkbox for Anonymous Access. If users will be accessing this site via netscape then you will have to check the Basic Authentication box and add the default name for the user accounts. Apply all settings, restart the iis service just for grins and you should be set. Hope this helps.

Collapse -

Password Protecting FrontPage Webs

by mike_jose In reply to Password Protecting Front ...

You want me to leave Anonymous Access, Basic Authentication, and IWA all unchecked, right? I tried it and it didn't allow me to view the page in my IE browser and I do have permissions to this folder and in when I try to open it up in FrontPage using, again http://mydomain.com/folder it doesn't open it up nor does it prompt for a password.

Collapse -

Password Protecting FrontPage Webs

by banyanman In reply to Password Protecting Front ...

IWA and Basic Authentication should be checked. Have you verified that the name of your default document is listed under the documents tab if it is not name default.asp or default.htm? double check your settings.

Collapse -

Password Protecting FrontPage Webs

by mike_jose In reply to Password Protecting Front ...

My default document is named defaul.htm and that this is already under the documents tab. When I check BA & IWA it partly works, meaning it prompts for the domain name/password when trying to open the frontpage web files in frontpage using http://mycompany.com/folder as the web name. But when I open up my IE browser and enter in http://mycompany.com/folder/defaul.htm in the url bar, it's also prompting for a username & password and I don't want it to.

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums