PC's can't see each other (firewall off)

By yashy99 ·

I have PC1 and PC2. PC1 is directly connected to an Access Point via ethernet (D-link 2100AP) and has been configured fine and can access the internet. PC2 uses a wireless usb adapter to connect to the internet. The router is a netgear DG834G and provides DHCP.

PC1 ip:
Access Point ip:

PC2 ip:

PC1 and PC2 can't see one another! They can't ping each other.

PC1 can ping the wireless AP and so can PC2, just not each other.

Both of the PC's have windows firewall turned off. They have comodo internet security, but even when I disabled that, it doesn't work.

Could this be the router firewall? If so, does anybody know if there's some kind of advanced settings I need to modify?


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

My guess is:

by robo_dev In reply to PC's can't see each other ...

since PC1 has a static IP address, I would double check that the subnet mask and gateway that were assigned manually are the same as the ones assigned by DHCP to PC2.

Have you tried enabling DHCP in PC1?

Are these VISTA PCs? Vista can do weird things, network-wise.

Remember that the AP is a mac-layer bridge, and the ethernet side of the Netgear is a simple layer-2 switch, so from a network standpoint, your AP connected PC should act just like an Ethernet-attached PC.

Collapse -

Can't ping PC's

by yashy99 In reply to My guess is:

Thanks for responding.

PC1 has a static IP. So does PC2, which is what baffles me. I haven't manually assigned any IP's to any of them.

Both machines are running XP. PC1 is on XP Pro, PC2 is on XP HOME.

Collapse -

Check subentmask / Assigh DHCP / Disable or uninstall Comodo

by TommyDeca In reply to Can't ping PC's

Did you try what robo_dev said, and assign DHCP on both machines?

Seems strange that both pc's have static ip-adresses, and you haven't manually assigned these. Can you tell us the subnet mask that is in use on these computers?

Step 1: Assign DHCP
Step 2: Check Comodo Firewall / Disable / Uninstall completely.

Related Discussions

Related Forums