General discussion

  • Creator
    Topic
  • #2130365

    Permission Problem Scheduled Batch File

    Locked

    by mike.brooks ·

    I have a batch file which I would like to schedule to run using WIN AT. However, the purpose of this batch file is to run some backups (of an Oracle Database) with the output going to a Folder on another server (W2K). If I run the batch file from the server at a command prompt it works fine (because the server logon name has permisssion to write to the W2K folder in question). However, when scheduled using WIN AT (and it is important to schedule this job), then the batch file does not have the correct permissions to write to the folder. Has anyone got any ideas how I can get around this problem?

    Regards
    Mike Brooks

All Comments

  • Author
    Replies
    • #3549807

      Permission Problem Scheduled Batch File

      by jasmith ·

      In reply to Permission Problem Scheduled Batch File

      What account does the WIN AT service run as? Give that account the appropriate permissions (or change the account to one that has the proper permissions), restart the service, and try it again…

      Good luck!
      James Smith

      • #3556266

        Permission Problem Scheduled Batch File

        by mike.brooks ·

        In reply to Permission Problem Scheduled Batch File

        WIN AT is a graphical front end to the Windows Scheduler service. I cannot seem to change the scheduling service to have any other permissions apart from ‘System’. I think I will have to have a look at another scheduler.

    • #3549700

      Permission Problem Scheduled Batch File

      by frec1 ·

      In reply to Permission Problem Scheduled Batch File

      Share the folder and give everybody full control or the appropraite account full control.

      FREC!

    • #3549582

      Permission Problem Scheduled Batch File

      by lukemc ·

      In reply to Permission Problem Scheduled Batch File

      Create a domain account called something like “schedule_service” and add that account to the domain admins global group.
      Then change the schedule service on the box you are runnig the script from to startup using the account you created (through the services => schedule service). As long as the W2K server is in the same domain as the server you are scheduling your script to run on, and the local admins has access to the directory and share, the script will run successfully.

      • #3556268

        Permission Problem Scheduled Batch File

        by mike.brooks ·

        In reply to Permission Problem Scheduled Batch File

        I have no options to change the schedule service – just ‘System’ grayed out. I will be looking at alternative scheduling products I think.

    • #3556265

      Permission Problem Scheduled Batch File

      by mike.brooks ·

      In reply to Permission Problem Scheduled Batch File

      This question was closed by the author

Viewing 3 reply threads